Rockbox

Tasklist

FS#9975 - Improve the strnatcmp function

Attached to Project: Rockbox
Opened by Alexander Levin (fml2) - Monday, 02 March 2009, 20:38 GMT
Last edited by Alexander Levin (fml2) - Monday, 02 March 2009, 21:36 GMT
Task Type Patches
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Version 3.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The recently introduced "natural sorting" function places (for example) cyrillic characters before latin. The usual strcmp does it the other way. For files without digits in the name both functions should give the same result.

The difference seem to be caused by the usage of char for internal work. Changing that to int makes everything straight.
This task depends upon

Closed by  Alexander Levin (fml2)
Monday, 02 March 2009, 21:36 GMT
Reason for closing:  Accepted
Additional comments about closing:  Committed in r20180

Loading...