Rockbox

Tasklist

FS#9980 - bookmarks fail to create when using microSD cards

Attached to Project: Rockbox
Opened by Bryan (bryan.brake) - Tuesday, 03 March 2009, 15:58 GMT
Last edited by Magnus Holmgren (learman) - Sunday, 08 March 2009, 14:57 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I posted this in the "general discussion"... probably did not get a response because I should have put it here... I also do not know if this affects other players that have external card slots.
-----------------------------------------------------------------------------------------------

I use ogg files, and have recently decided to start turning my CD collection into .flac. A little background:

I use "grip" to encode them to flac. I just bought a 16GB microSDHC, which rockbox sees just fine in my Sansa E260R. Can copy files to and from the player using the players interface. Can play music in flac from the card just fine. The problem comes when I attempt to power down the player. The first message says "shutting down", followed by a second message that says "Bookmark Failed". The system starts up, and I navigate to the card, only to see no bookmarks.

I tested further. I loaded an .ogg file onto the card, played the song to about halfway, then did a shutdown, I got a "shutting down", followed by "bookmark failed". I start up the system, and I go to the card, and I see the directory I copied to the card with my song in it, the flac that I copied to the card, and the .bmark file. selecting the bmark file shows current bookmarks for that artist.

After this, I went to "Recent Bookmarks" and looked, and not only did I see the .ogg that I just made, but also a bookmark for the .flac that I had played before. I could select the bookmark, and play the .flac from the card with no incident. The problem is, there is no .bmark file anywhere on the device for that artist. Not in main memory, or on the card. It created a bookmark, but says it failed to create one.

I believe that it says it failed to create the .bmark file on the card, but somewhere on the device, there is a bookmark created for that song.

Has anyone had this issue? I'm running "r20108-090226". If there have been updates that address this, I've no problem updating...


**UPDATE**: I updated to r20168-090302, and the problem still exists. the .flac I'm playing off the card still gives a "bookmark failed" when I shutdown, but the bookmark is created and seen under the "Recent Bookmarks". And I still cannot find the .bmark file that is supposed to be created. I can also confirm the same issue occurs with an ogg file of Antonin Dvorak's "from a new world". I don't have any mp3s to test, but I would imagine the same thing occurs.

**UPDATE #2** Originally, I posted that the .ogg file on the microSD card created a .bmark file. this is the case. Later, I attempted to shutdown and create a bookmark using a different ogg file, that did not exist in a sub-directory. This did fail. The bookmarks on the microSD fail only when music files are not in a sub-directory, and I just copy them to the "root" of the card. If I create a directory, and put the files into it, the system creates a .bmark file. Crazy huh?
This task depends upon

Closed by  Magnus Holmgren (learman)
Sunday, 08 March 2009, 14:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  Thanks for reporting. Enough details to make it easy to find the problem. :)
Comment by Magnus Holmgren (learman) - Saturday, 07 March 2009, 10:52 GMT
If "Maintain a list of recent bookmarks" is enabled, then bookmarks are actually created in two locations. First it creates an entry for the recent bookmarks list, which is a special .bmark file in the .rockbox folder, then the .bmark file you're looking for is created/written to. So the fact that the bookmark shows up in the recent bookmarks list is not surprising in this case.

The remaining question is why it fails to write a bookmark file to the root of the SD card. I'll see if I can reproduce that here.
Comment by Magnus Holmgren (learman) - Saturday, 07 March 2009, 11:32 GMT
Okay, that was easy to figure out. :) This patch fixes the problem. When creating a bookmark in the root of an extra volume (like an SD card), the bookmark is written to a file called volume_root.bmark, similar to the root_dir.bmark when bookmarking a file in the root directory.

Loading...