Rockbox mail archive
Subject: RE: Hungarian Notation (was: [patch] peakmeter)
From: Stuart Tedford (stuart.tedford_at_piresearch.co.uk)
> -----Original Message-----
> From: Josh Nisly
> I've fixed a number of bugs where someone accessed member variables
> thinking they were local ones. Using m_ prefix makes it very hard to
> mistake these.
Yes, I haven't done any commercial c++ development yet, but I can see that
this "m" prefix would be valuable.
I guess it's important to have coding conventions that help us, not simply
for conventions sake. The best convention is one that applies only the
useful parts from other conventions. Like Bjorn said, I don't see how
pszFullHungarianNotation uiIs fpulUseful. A blanket use of prefixes like
this simply makes the code hard to read and doesn't draw your attention to
vars that genuinely require special attention - like pSomeVar and mSomeVar.
Page was last modified "Jan 10 2012" The Rockbox Crew