Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: Can't get WPS to work right. -- further info.

Re: Can't get WPS to work right. -- further info.

From: Michael O'Quinn <michael_at_oquinn.info>
Date: Wed, 16 Apr 2003 15:06:43 -0700 (PDT)

On Wed, 16 Apr 2003, Brent Geery wrote:

> OK, things are even stranger. I swapped the order of the lines, and
> now it functions! This is very odd, and must be a bug of some type.
> Again, the following WPS works:
>
> First line: %pr%pb%bt
> Second line: %s[%pn %pp/%pe] %fskb %pt %fbkbs/%ffhz: %?it<%it - |%fn -
> >%?ia<%ia - |%d2 - >%?id<%id |%d1 >%?iy<(%iy)>
>
> But, the following does not, with the second line being totally blank:
>
> First line: %s[%pn %pp/%pe] %fskb %pt %fbkbs/%ffhz: %?it<%it - |%fn -
> >%?ia<%ia - |%d2 - >%?id<%id |%d1 >%?iy<(%iy)>
> Second line: %pr%pb%bt
>
> Both are exactly the same, only swapping the order of the lines.

I tried the one that's not working for you. I tried it twice, once with
the last line unterminated, and again with the last line terminated by
hitting enter. When cutting and pasting, I assumed that you intended a
space where the first line wrapped, as in "n - >" not "n ->".

Both worked on my Studio 10, ROM 5.08, Latest RockBox Daily CVS-030416
from the website.

On a slightly different but not completely unrelated note, have you tried
"%pf"? It's a graphical progress bar specifically for the Player/Studio.
It makes the Player "feel" like a completely different machine to me. It
needs to go on a line all by itself, but IMHO it's really awesome, and
totally worth having to cram everything else on the single remaining line.

Good Luck!
Michael
Received on 2003-04-17

Page was last modified "Sat May 23 08:12:40 2020" The Rockbox Crew