dev builds
themes manual
device status forums
mailing lists
IRC bugs
dev guide

Rockbox mail archive

Subject: Re: Sansa Clip+ won't turn on

Re: Sansa Clip+ won't turn on

From: Glenn via rockbox <>
Date: Sat, 30 Jan 2016 17:50:09 -0600

Also Pablo,
I hate to suggest the obvious, but sometimes we overlook the obvious.
Did you test the power source?
If you are charging off of a cable, it could be bad, or the PS could be bad.
----- Original Message -----
From: "bunn via rockbox" <>
To: "Rockbox" <>
Cc: "bunn" <>
Sent: Saturday, January 30, 2016 5:22 PM
Subject: Re: Sansa Clip+ won't turn on

few years ago I had an issue that sounds a lot like your problem, try
holding the power button for a few minutes and see if it boots

On 1/30/2016 16:57, pablo f. zavalia via rockbox wrote:
>> I haven't looked in the manual for this one, but it seems to me that you
>> can
>> make it boot differently with holding both the power button and either
>> the
>> up arrow or down arrow together.
>> I would think that even if the battery was toast, it would power up from
>> the
>> USB cable.
>> Glenn
> Yes, I tried all possible button combinations. It's odd also that it
> doesn't
> show up on my computer at all whem plugged. It makes me think there may be
> some
> hardware issue, maybe. It's odd because it's not like it fell from the
> table or
> got wet, it was working fine one second and the next dead.
> I think I'll need to start thinking about desoldering/shortcicuit things,
> but I
> wanted to see if any one had this issue or may suggest an idea.
> Thanks for your help Glenn
> Pablo
> -------------------------------------------------------------------
> Unsubscribe:
> FAQ:
> Etiquette:


Received on 2016-01-31

Page was last modified "Jan 10 2012" The Rockbox Crew