Rockbox mail archiveSubject: Re: Working towards skin engine 2.0 (includes RFC on code!)
Re: Working towards skin engine 2.0 (includes RFC on code!)
From: Magnus Holmgren <magnushol_at_gmail.com>
Date: Mon, 7 Nov 2011 14:54:55 +0100
On Mon, Nov 7, 2011 at 14:30, Jonathan Gordon
> They are a bit wordy but I don't think it really is a big deal.
I agree that the macros are a bit long. Also, there are no "_" chars
to separate things, making them a little harder to read. What about
changing SKINOFFSETTOPTR to SKIN_TO_POINTER and PTRTOSKINOFFSET to
SKIN_TO_OFFSET? Not much shorter perhaps, but easier to read. And the
"from" part isn't that important, IMHO.
> I'll have a testable patch tomorrow. Unfortunately testing is probably
> going to mean commiting and praying because we have no way to test
> every single tag and its different uses which is what is really
What? You don't have a set of monster-WPS:es that exercise all tags? :)
-- MagnusReceived on 2011-11-07