Rockbox mail archiveSubject: Re: Working towards skin engine 2.0 (includes RFC on code!)
Re: Working towards skin engine 2.0 (includes RFC on code!)
From: Thomas Martitz <kugel_at_rockbox.org>
Date: Tue, 08 Nov 2011 12:58:19 +0100
Am 07.11.2011 14:54, schrieb Magnus Holmgren:
> I agree that the macros are a bit long. Also, there are no "_" chars
> to separate things, making them a little harder to read. What about
> changing SKINOFFSETTOPTR to SKIN_TO_POINTER and PTRTOSKINOFFSET to
> SKIN_TO_OFFSET? Not much shorter perhaps, but easier to read. And the
> "from" part isn't that important, IMHO.
Apart from the lengthy names (perhaps SKIN_2OFF, SKIN_2PTR?), it looks
like the first parameter is exclusively "skin_buffer". If that's true,
can't it be omitted somehow?
Received on 2011-11-08