Rockbox mail archiveSubject: Re: Working towards skin engine 2.0 (includes RFC on code!)
Re: Working towards skin engine 2.0 (includes RFC on code!)
From: Jonathan Gordon <jdgordy_at_gmail.com>
Date: Tue, 8 Nov 2011 23:02:58 +1100
On 8 November 2011 22:58, Thomas Martitz <kugel_at_rockbox.org> wrote:
> Am 07.11.2011 14:54, schrieb Magnus Holmgren:
>> I agree that the macros are a bit long. Also, there are no "_" chars to
>> separate things, making them a little harder to read. What about changing
>> SKINOFFSETTOPTR to SKIN_TO_POINTER and PTRTOSKINOFFSET to SKIN_TO_OFFSET?
>> Not much shorter perhaps, but easier to read. And the "from" part isn't that
>> important, IMHO.
> Apart from the lengthy names (perhaps SKIN_2OFF, SKIN_2PTR?), it looks like
> the first parameter is exclusively "skin_buffer". If that's true, can't it
> be omitted somehow?
> Best regards.
skin_buffer is a placeholder. In all likelihood this will end up being
different for each skin (usually core_get_data(data->buffer)).
Received on 2011-11-08