Rockbox mail archiveSubject: Re: Working towards skin engine 2.0 (includes RFC on code!)
Re: Working towards skin engine 2.0 (includes RFC on code!)
From: Frank Gevaerts <frank_at_gevaerts.be>
Date: Sun, 13 Nov 2011 15:09:01 +0100
On Wed, Nov 09, 2011 at 12:17:02AM +1100, Jonathan Gordon wrote:
> I'm not entirely sure what to do about the conversion macros. I am
> going to keep the OFFSETTYPE() one (though open to a better name)
> because it is helpful).
Is it really? I can't say I'm convinced,
If someone could come up with a way to make OFFSETTYPE() actually *do*
something (a clever way to do type checking, maybe), I'd agree. The way
it stands now it's just as easy to overlook as a comment when changing
things, and *nothing* will complain (the thing given there doesn't even
have to be a valid type...).
-- "Debugging is twice as hard as writing the code in the first place. Therefore, if you write the code as cleverly as possible, you are, by definition, not smart enough to debug it." - Brian W. KernighanReceived on 2011-11-13