ID Task Type Category Priority Summary Opened Opened by Last Edited Operating System
13287Feature RequestsPlaylistsVery LowSaving the current playlist should then load the newly ...2021-04-17dconrad12021-04-21All players Task Description

If the user modifies the currently active playlist and then saves it, rockbox should load the newly saved playlist and resume it to the same position/state it was in.

This would make it easier to deal with the fact that Bookmarks don’t work with modified/dynamic playlists. Currently, in order to bookmark in a modified playlist, the user needs to save the playlist, stop playback, go manually find the playlist, load it, manually find where they were when they wanted to bookmark, and only then can a bookmark be created.

I have tried my best to see if I could do this, but I just don’t think my skills are up to the task.

13286BugsPlaylistsVery LowUnable to create bookmark after any playlist-altering a...2021-04-15dconrad32021-04-15All players Task Description

Build of git commit 42dba70, tested on Eros Q

Bookmarks work normally if a file is played from the file browser by pressing select on a file.

If any playlist altering action is taken, the “Create Bookmark” item is no longer in the context menu, and the prompt to create a bookmark is no longer present upon stop if that feature is enabled.

To reproduce (this is probably not an exhaustive list):
1. in file browser, context-menu on a file and go to Current Playlist → Clear List & Play Next. Erase current dynamic playlist.
2. In WPS Context menu, the Bookmarks item is not present at all.

1. Play a file from a directory with multiple files. Erase current dynamic playlist.
2. In WPS Context menu, note Bookmarks item is present, and Create Bookmark is present within.
3. Go to current playlist from Context Menu. Remove or Move a track, it does not appear to matter whether it is before or after the current playing track.
4. In WPS Context menu, Bookmarks item is present, but Create Bookmark is not present within it.

13284BugsMusic playbackVery LowStuttering playback on Clip Zip2021-04-07rasferret2021-04-07Sansa Clip Zip Task Description

This problem bugs me for a long time. Sometimes, when I start the playback of a file too soon after startup, the playback starts to pause regularly for a few seconds. At the same time the ui is very unresponsiv. Stopping the playback and waiting for some time, resolves the problem.
I am listening podcasts at 250% playback speed exclusively and start the playback normally by selecting the latest bookmark.

13283BugsPluginsVery LowPictureflow segfault on targets with a portrait display...2021-04-06amachronic32021-04-07All players Task Description

Entering and exiting Pictureflow multiple times will eventually generate a segfault. This can be reproduced on the simulator quite easily. Despite the apparent ‘random’ nature of the segfault, GDB and Valgrind show it is always caused by the same line of code.

Oddly enough, it only occurs for portrait display orientations (LCD_HEIGHT > LCD_WIDTH). Weird :-/. Square and landscape displays are fine, which would explain why nobody seems to be complaining… AFAICT, portrait displays are much less common especially among the stable ports.

I tested using the Sansa Fuze+ (portrait), Sansa Clip Zip+ (square), and iPod 6g (landscape) simulators.

The bug is on master, was introduced by 45915101d according to ‘git bisect’, and I confirmed it does not appear on the preceding commit (9adfab9b2).

The problem lies in the function render_slide(), on the indicated line:

        int p = (bmp->height-1-DISPLAY_OFFS) * PFREAL_ONE;
        int plim = MAX(0, p - (LCD_HEIGHT/2-1) * dy);
        pix_t *pixel = LCDADDR(x, (LCD_HEIGHT/2)-1 );

        if (alpha == 256) {
            while (p >= plim) {
                *pixel = ptr[((unsigned)p) >> PFREAL_SHIFT]; /** <<< HERE **/
                p -= dy;
                pixel -= PIXELSTEP_Y;

I think ‘p’ must have a bad value, but it kept getting optimized out (even after recompiling with -O0) so I was unable to confirm this in GDB. I can see ‘pixel’ and ‘ptr’ and they appear sane.

Running the simulator under Valgrind is the most reliable way to reproduce the bug. Valgrind does run cleanly on 45915101d and master for square and landscape displays, so it is definitely the portrait orientation that triggers this.

Here’s the Valgrind error I got from testing on a Fuze+ simulator build of 45915101d:

==69170== Invalid read of size 2
==69170==    at 0x4BB2F67: render_slide (pictureflow.c:2708)
==69170==    by 0x4BB30FE: render_all_slides (pictureflow.c:2848)
==69170==    by 0x4BB4BF8: pictureflow_main (pictureflow.c:3684)
==69170==    by 0x4BB4BF8: plugin_start (pictureflow.c:3870)
==69170==    by 0x4BB6998: plugin__start (plugin_crt0.c:102)
==69170==    by 0x143586: plugin_load (plugin.c:961)
==69170==    by 0x157309: ft_enter (filetree.c:652)
==69170==    by 0x150672: dirbrowse (tree.c:707)
==69170==    by 0x150E47: rockbox_browse (tree.c:1021)
==69170==    by 0x12C8E5: plugins_menu (plugin_menu.c:57)
==69170==    by 0x12B9BF: do_menu (menu.c:636)
==69170==    by 0x143EDA: miscscrn (root_menu.c:347)
==69170==    by 0x1444E6: load_screen (root_menu.c:687)
==69170==  Address 0x4392fa8 is not stack'd, malloc'd or (recently) free'd
13282BugsRemoteVery LowiPod Radio Remote functionality has regressed since 3.1...2021-04-05ThePhxRises102021-04-16iPod 5G Task Description

Radio Remote support is incredibly unstable on the newest daily builds (presumably since 77f8c9c).

While the stable build did not actually support the FM Radio functionality (and I haven’t gotten it to work on the newest dev builds either, despite the menu option now appearing), its remote functionality worked far better. On the current builds remote buttons only work one out of several attempts to connect the device. Getting it working requires a trial and error of several reboots and unplugging/plugging the remote in repeatedly. I have also seen the buttons on the remote cause rockbox to crash. None of this behavior exists in the 3.15 stable build.

Another thing is that the buttons on the remote seem to now control rockbox’s volume when they did not used to. They should not be doing so, since the radio remote uses the iPod’s line out signal and controls its own volume independently of the player. Not to mention that these controls currently bypass any maximum volume limits set in rockbox.

13276BugsUSB operationVery LowxDuoo X3ii: system crash after unplugging USB-C power s...2021-03-19murmel32021-04-07xDuoo X3ii Task Description

testing FW: 714f7a21da-2103*

after disconnecting a general purpose power supply (SONY 5V 1500mA) system crashes with:

mount: 0

a restart is immediately possible by pressing (NEXT) “lowest right button”

13273BugsUSB operationLowUSB Mass Storage Mode Does Not Work With Flash Adapter2021-03-15ThePhxRises92021-04-231iPod 5G Task Description

As of the daily build from March 12th (and continuing to the 14th’s) attempting to transfer files over USB Mass Storage mode while using a common flash adapter for an iPod Video results in a halted transfer after a few seconds. It also results in Rockbox being stuck in USB mode until it’s rebooted, even after it is unplugged. I am not sure if this behavior existed in daily builds prior to the 12th, but it definitely exists in the 3.15 Release build. I have been told that this issue also affects builds on the iPod Classic. As far as I can tell, I believe Power Management would need to be disabled entirely when these flash adapters are detected (or by a manual toggle in settings) in order to allow proper USB file transfers.

UPDATE: After testing a build from the 11th (before the newest ATA changes), the same problem seems to persist. It may be important to note that I am using an unbranded “green board” and Digigear branded CF adapter, rather than the corresponding iFlash brand adapter. However this shouldn’t change Rockbox’s perception of them as they both show Power Management and Advanced Power Management as “unsupported” in Disk Info. The DMA mode is however listed as UDMA 2, whereas I was under the impression that these flash adapters functioned better under UDMA 1 and that an earlier commit had addressed this.

13268Feature RequestsApplicationsVery LowSupports png format for album artwork2021-02-25ltx216442021-02-25All players Task Description

Most of the Japanese music artwork I purchased on iTunes has png format files registered.
Currently only bmp and jpg files are supported.
Normally, it can be handled by converting the artwork of the music file, but continuing to support only the old age format means that the music library will be adapted to the old age accordingly.
I think that if you want to manage the data rationally, you should support the default of the music store.

13265BugsMusic playbackVery LowChannels reversed on ipod nano 2g2021-02-10jamestheboss0812021-03-12iPod Nano 2G Task Description

Left channel comes out of right ear and right channel comes out of left ear. When selecting mono left, it plays the left channel so that works fine. It also plays fine through my ipod when not on rockbox so Im pretty sure its just a software issue.

13263BugsApplicationsVery LowRockbox Deletes Wrong File2020-12-26shakestir52021-03-09All players Task Description

I press Delete while Track 1 is playing and get this prompt:

 /Track 1.mp3
 Any Other = No

If Track 2 starts playing before I press SELECT, Track 2 is deleted instead of Track 1.

13257BugsUSB operationVery LowUSB Mode setting is ignored and always asks till WPS is...2020-11-16bahus52021-02-04AGPTek Rocker Task Description

I’ve set USB Mode to Charge Only but this setting is applied only after I open WPS screen. If after setting change I simply exit settings menu to main rockbox menu (no music is played) - it asks on USB insert.
The same behavior after reboot. So if I switch it on and it’s loaded to main menu and then I insert USB - it always asks. Setting is properly applied only after I open WPS screen.

13256BugsMusic playbackVery LowXduoo X3II : unable to play some flac and mp3 files pot...2020-11-14Zabizabo82020-12-041xDuoo X3ii Task Description

Hi there,

I’m using Rockbox on my Xduoo X3II with the build 4e54996 but the problem is the same since the build 0c99a3f. I never tried with builds previous to the 0c99a3f one.

Some Mp3 or Flac files can’t be read by Rockbox while there aren’t reading problems with the Xduoo firmware.

First, I was thinking it was relatd to the music files but I have looked precisely and I see they share a common problem : when the size of the cover art (named cover.jpg)in the folder album is bigger than 2.3 Mb, the covers can’t be shown on the screen player and the files can’t be played.

I have checked this problem on several album folders. Once I got a file working despite a cover art of 3,7 Mb.

Tell me how I can help you : providing files or cover art (or both), I will do.

My best and thanks

13255PatchesLanguageVery LowUpdated Hungarian translation2020-11-10bekesi.gergely2020-11-101All players Task Description

Hi All,

Some updated Hungarian translations.
Kind regards

13253BugsOperating System/DriversVery LowUnable to shutdown ipod 4G Greyscale with long press of...2020-10-30Scampi74152021-04-22iPod 4G Grayscale Task Description

Using Rockbox version 2d85c72151-201030
On an ipod 4th Generation (Greyscale)
Hardware revision 0×00050014 PP version: PP5020E

I’m unable to shutdown rockbox by long pressing the play button on the clickwheel as instructed in the manual.

13252BugsMusic playbackVery LowHolding Next/Prev to scroll (browser) while playing mus...2020-10-30impig42021-04-20xDuoo X3ii Task Description

Holding (as opposed to pressing it repeatedly) the “next” or “prev” button to scroll through a large list of files in the file browser or in the database while playing music, stops the music playback which then cannot be resumed until restart.

I’m testing this on xDuoo X3ii with the latest dev. build 7c498b9043.

* start playback (it seems the file format is not important)
* while music is playing go to the file browser or the database which has a few screens long list of entries
* start scrolling through the list by holding the “next” or “prev” button (don’t release)
* in a few seconds (while scrolling) the playback may start to skip and the scrolling starts to lag. In about 10 seconds the playback stops.
* release the button

Menus work, playback screen shows the current track (playback indicated with the play icon but no sound being played and progress bar not moving), you can switch to a new track and it will be shown as the current - but no actual playback. Play, pause is registered, but makes no difference.

Waiting for a minute not pressing anything doesn’t resolve the issue.

The only solution to the “lockup” I found is to restart the player.

- doing the same while NOT playing music causes menu lag, but playback is possible afterwards
- pressing “next”/”prev” button to scroll through the list doesn’t lockup the player

Thanks for your continued support!
Best, iMpig

13251BugsCodecsVery LowPlayback stutters when playing Apple .m4a files2020-10-2520esproductions122020-12-062iPod 4G Grayscale Task Description

When a .m4a file is played, particularly one bought from the iTunes store, it seems to overwhelm the AAC codec in rockbox.

I think it may be something to do with the ‘anti-skip buffer’ but I cannot confirm this for sure, but it seems related, as in the stable release (3.15) playback works fine and the HDD Access indicator in the corner is only displayed briefly during the beginning of playback. In the latest development build (Rev. 3fbca49) and a few previous, however, the HDD access indicator stays on screen at all times during stuttery playback, the whole system becomes slow and almost impossible to use and sometimes locks up completely.

I have confirmed this on my iPod 4G color, it seems to be only on older iPods, as my 6th Gen classic plays them fine!

IMPORTANT NOTE: I am using an iFlash solo + 128GB SD in the iPod. Haas surround 5ms is enabled along with +3db tone control on both bass and treble

13250BugsFM TunerVery LowFM radio recieving function not working as expected iPo...2020-10-2320esproductions42021-03-21iPod 4G Grayscale Task Description

When Using FM Reciever within Apple Radio Remote with any of my iPods that support the function (in Rockbox), it either does not appear (Not detected at all in FM debug menu) in the latest stable version (3.15), or in the case of the latest daily builds, it appears to detect the FM hardware, and will attempt a search.

The ‘FM Radio’ menu in the debug menu of rockbox version 2cf75bf008-201023 states the following:

HW Detected: yes
PI:0000 PS:’ '
CT1970-01-01 00:00

An odd clicking sound may be heard, like interference from within the iPod.
The Radio remote works fine as it should in OF, indoors and outdoors

Rockbox functionality tested indoors and outdoors.

The remote control and audio functions work flawlessly (play/pause/volup/voldown/prev/next) when playing music from the iPods internal library.

Similar behavior seen between 1st gen nano, iPod 4G Colour and the 4G mono
with two different Radio Remotes.

13249BugsThemesVery LowSBS Info viewport not refreshing when used as a conditi...2020-10-20lebellium12020-10-313All players Task Description


The SBS info viewport does not refresh automatically when used as a conditional and the value has changed.
One needs to enter any menu (Files, settings etc…) and get back to the home screen to force the viewport refresh.

Tested on Onda VX747 UI Sim for Windows (old 2018 build from rasher) and on target (YP-R1 fresh build edbdefa09a-201018)

Simple examples with playback mode (%mp) and repeat mode (%mm) conditionals:

Status: %?mp<Stop|Play|Pause|Ffwd|Rew|Rec|Rec pause|FM|FM pause>
Button: play/pause
Status: %?mm<Off|All|One|Shuffle|A-B>
Button: repeat mode
13244BugsUser InterfaceVery LowCUEsheet + File: "Currently (playing) of all" numbers a...2020-10-05impig2020-10-05xDuoo X3ii Task Description

When playing a single album file along with a .cue-sheet file (for track listing & metadata) the numbers reported on screen eg. “1 of 5” are wrong.

Actually the second number reported is in reality for the number of cuesheets within the directory, which is not what the user expects.

What a user wants (I believe) is to show the numbers relevant within the current cuesheet (album) - number of the currently playing track out of all album tracks.

It’s interesting that the tracks are otherwise correctly marked on the progress bar and all playable (skipable to), it’s just the numbers that are wrongly reported.

I tested two “default” themes to make sure it’s not a theme problem.
Also “File view > Show files” (showing cuesheets or not) setting does not change this behavior.

Tested on xduoo x3ii, dev build ef34126913

13243BugsApplicationsMediumTree scrolling not showing end of text2020-10-04bahus32021-03-10All players Task Description

With default scrolling settings (in particular Settings → General Settings → Scrolling → Screen Scrolls Out of View set to No) on my Xduoo X3 I’m unable to see end of text using tree scrolling feature (Play + Next)
For instance with folder name:
2012 - Greatest Hits 1993 - 2010 [Malaysia Edition]
Scrolling with Play + Next scrolls only to “Edit” part and “ion]” is missing.

Also with Screen Scrolls Out of View Set set to Yes I think it’s better stop scrolling when end of text is reached (so basically ignore this setting when doing manual scrolling). Or at least stop right after text is hidden.

P.S. Thanks for implementing tree scrolling for Xduoo X3 so quickly (

13242Feature RequestsCodecsVery LowSupport Super Audio CD formats (dsf, dff, dsd)2020-09-30bahus42020-09-30All players Task Description

As there are multiple targets that support such formats in OF (all Xduoo players, Agptek Rocker…) would be cool to have it in rockbox too. Not sure if it’s really useful but there is open source library for decoding such formats written in C:

13238BugsCodecsLowHaas surround + timestretch causes crash2020-09-05Bilgus2020-09-05All players Task Description

Steps to reproduce

time stretch = false
Haas surround = disabled

Play Song

enable timestretch
enable Haas Surround

Tracked crash down to here:

static void dsp_surround_flush(void)

  memset(core_get_data(handle), 0, SURROUND_BUFSIZE);


removing the memset stops the crash at the expense of dirty data blasting in your ears

testing the handle doesn’t help the handle is valid as far as buflib is concerned

13219BugsCodecsVery LowAPE 24/44.1 - harsh noise2020-07-25clasatas12020-09-101All players Task Description

Playing APE 24/44.1 with harsh noise in different parts of the track. If you decode APE file to WAV using the codec console, then there are no problems. So the matter is in the player’s APE decoder.

At 24/48 everything is fine.

13217BugsCodecsMediumStuttery playback when playing 320k Mp3s Synched via it...2020-07-15uservidpod2020-07-15iPod 5G Task Description

Playing 320K MP3s pauses often in Version 3.15 and daily build 7d00533 also UI becomes unresponsive
Version 3.14 or older does not reproduce the issue in either 44 or 48khz sampling rate and same sound options
Is not reproducible under OF or Version 3.15 running on IPOD 6G
seems to be a cpu usage issue as compiling a version of rockbox with much higher than stock CPU clocks seems to alleviate the issue to an extent but there is still occasional pauses that is not present after reverting to 3.14 and stock 80 mhz clock speed.

13201BugsSettingsVery LowTime resets after rebooting.2020-06-04Sophos2020-06-04iPod 1G/2G Task Description

Hello there,

When I reboot my Rockboxed iPod nano second generation, it changes the time +5 hours.

Does anyone know why this can be? Thanks

13198BugsUtilsVery Lowipodpatcher and Rockbox Utility do not work in macOS Ca...2020-05-22tarasis12020-06-291All players
13196BugsUser InterfaceVery LowXduoo X3ii: album art doesn't show for some jpgs in con...2020-05-08johnbtracker32020-07-171Another
13193PatchesConfigurationVery LowAdd option to disable settings reset on startup2020-04-01cockroach12020-04-032All players
13188BugsConfigurationVery LowQuickscreen entries cannot be removed2020-02-03keks242020-02-03All players
13178BugsDatabaseVery Lowall titles in database 2x, even after several rebuilts2019-09-08shiftF1222019-09-112iPod Classic
13175BugsUtilsVery LowScreendump Causes PANIC (iPod Classic build 4ed5727654-...2019-05-02codyteam12019-05-19All players
13174BugsPluginsVery LowRockboy Volume issues (iPod Classic Build 4ed5727654-19...2019-05-02codyteam2019-05-02iPod Classic
13166BugsCodecsVery LowiRiver H300 ALAC codec crashing (CPU frequency switchin...2018-12-28RDP2018-12-28Iriver H300 series
13161BugsFM TunerVery LowiPod FM Remote not working2018-07-29the_unconventional2018-07-29iPod 4G Grayscale
13159BugsCodecsVery Lowrockbox hangs on certain m4a files2018-07-03speachy52020-06-25All players
13158BugsMusic playbackVery LowUnable to play for ibasso dx 90 2018-05-23xy170477072018-05-23Another
13156BugsRbutilVery LowCreating of talk files fails ungracefuly when encountin...2018-05-04fennectech22021-02-28All players
13150BugsRemoteVery LowX5 remote doesn't respond to button presses2018-03-14cereal_killer2018-03-14iAudio X5
13142BugsDriversVery LowSD card not recognized2017-12-26floriansnow12020-07-24Sansa Clip Zip
13141BugsPluginsVery LowImageviewer cannot render JPEGs properly with a 1x2,1x2...2017-12-20lspangler2017-12-201All players
13136BugsPlaylistsVery LowPlaylist position not saved on shutdown when using rela...2017-11-13TheAlmightyGuru22018-08-051Sansa Clip Zip
13132BugsRecordingVery LowIdle power-off in recorder causes loss of settings and ...2017-10-06TravisE2017-10-06Sansa Clip+
13129BugsOperating System/DriversVery LowIbasso DX90 build rev c6d5cd7 freeze when playing music2017-09-15lionerx2017-09-15All players
13122BugsMusic playbackVery LowAnnoying beeps when playing ogg vorbis files2017-07-04grmoht2017-07-04Sansa Clip Zip
13120BugsRecordingVery LowSansa e200v1: usb_storage_init_connection when recordni...2017-06-26fml22017-06-26All players
13118BugsMusic playbackVery LowIncorrect playback position when seeking AAC files down...2017-05-31cunt22021-02-031Sansa Clip+
13108BugsMusic playbackVery LowRandom crashes when playing music2017-03-16freeingdevices162017-12-16Sansa AMSv2
13106BugsMusic playbackVery LowResume Playback broken on iPod Classic2017-02-17ThurstonX32019-10-24iPod Classic
13103BugsPlaylistsVery LowShuffle mode can fail to operate on Insert during play2017-01-31chrisjj2019-08-171Creative ZEN
13102BugsPlaylistsVery LowDisengaging Shuffle mode can fail to unshuffle the list2017-01-31chrisjj2019-08-171Creative ZEN
Showing tasks 1 - 50 of 670 Page 1 of 14

Available keyboard shortcuts


Task Details

Task Editing