FS#10508 - Player gets stuck because of incorrect battery status

Attached to Project: Rockbox
Opened by Heinrich Münz (HMuenz) - Tuesday, 11 August 2009, 09:10 GMT
Last edited by Andree Buschmann (Buschel) - Wednesday, 27 July 2011, 19:38 GMT
Task Type Bugs
Category Battery/Charging
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Version 3.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Sometimes, when I boot my Sansa e260 (v1) into rockbox with a fully charged battery, it suddenly gets stuck after about 30 minutes, and the display tells me, that the battery is low. When I switch off the player and boot into rockbox again, the battery symbol indicates again, that the battery is fully (or nearly fully) charged. Now it's a game of chance: Will it play on correctly now, or will it get stucked again. Both can happen.

I have never had that problem before rb 3.3.

This task depends upon

Closed by  Andree Buschmann (Buschel)
Wednesday, 27 July 2011, 19:38 GMT
Reason for closing:  Out of Date
Additional comments about closing:  No further details since nearly 1 year.
Comment by MichaelGiacomelli (saratoga) - Tuesday, 11 August 2009, 18:07 GMT
Try running whichever version worked before for a while to see if this is a hardware failure. It sounds like you have a bad ADC.
Comment by Heinrich Münz (HMuenz) - Wednesday, 12 August 2009, 05:15 GMT
What is an ADC???
Comment by Dominik Riebeling (bluebrother) - Wednesday, 12 August 2009, 22:42 GMT
Tried asking wikipedia about it? Check
As that page is a disambiguition page, the correct meaning in this context is (all other technology meanings obviously won't match here anyway). It's a standard abbreviation in the electronics area.

As for your report: you never had that problem before release 3.3. But does the problem disappear when downgrading to an older version? If it's a hardware failure it unsurprisingly isn't related to the Rockbox version.
Comment by Heinrich Münz (HMuenz) - Thursday, 13 August 2009, 09:45 GMT
Ooops - thought ADC was something rockbox-specific - sorry.

I have been running rockbox 3.2 for a couple of days now - and everything works fine. Until now, the problem hasn't occurred anymore. I even played the same playlist where playback got stuck last time, but everything worked just fine. So it doesn't seem to be a hardware issue.

I also noticed that the scrollwheel didn't work correctly in rb 3.3, sometimes it seemed to be kinda locked. In rb 3.2 it works correctly again (unless the database is updating in the background). But that's possibly another bug.

Please tell me if you need any more information.
Comment by Heinrich Münz (HMuenz) - Tuesday, 18 August 2009, 11:11 GMT
I am still running rockbox 3.2 daily for hours without any problems. So i dare to say that this is definitely no hardware issue.
Comment by Bertrik Sikken (bertrik) - Saturday, 16 October 2010, 16:46 GMT
Does the problem still happen in e.g. 3.6 (or the upcoming 3.7)?