FS#10713 - can't mount nano 2g in xp, after r23288

Attached to Project: Rockbox
Opened by Turke (obzen) - Friday, 23 October 2009, 12:41 GMT
Last edited by Michael Sparmann (TheSeven) - Monday, 21 June 2010, 19:42 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System iPod Nano 2G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


USB mode should be disabled for now i guess. I couldn't mount my pod, after revision 23288. I can mount it by going back to an early build.

What happens is that, after i mount my ipod nano2g, pc recognises it as a storage drive, but only for a few seconds. After that, it freezes for a few seconds, the icon goes away from my computer, and comes back again, as a different storage device. Can't copy files to it, can't see the files inside. It shows "0" capacity in the properties window.
This task depends upon

Closed by  Michael Sparmann (TheSeven)
Monday, 21 June 2010, 19:42 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Not touched for ages, probably fixed by now.
Comment by Turke (obzen) - Friday, 23 October 2009, 14:36 GMT
....which seems to be fixed by the latest build.
Comment by Turke (obzen) - Friday, 23 October 2009, 14:51 GMT

FTL: Tried to put block 0 in o the pool !
Comment by Michael Sparmann (TheSeven) - Saturday, 24 October 2009, 19:59 GMT
Please always mention the exact revision number this happened with, otherwise it's impossible for me to try to track it down to a specific change.
In r23288 there were many known FTL bugs and USB was in fact disabled, so I wonder why you say we should disable it?
Comment by javier amor (chonps) - Wednesday, 04 November 2009, 19:01 GMT
First of all, excuse me for my very bad english
I have the same problem connecting a nano 2nd gen in Debian Lenny with revision r23514. When connecting iPod, gtkpod try to open but it freezes without show anything. I have to force quit and then the computer sees no device at all. To manage files in the player I have to reboot with original firmware and use gtkpod.
When this problem occurs, the fdisk -l command shows hard disks, usb drives, but not iPod even if connected. Mounting is imposible. Finally, the USB logo in the screen is impossible to make it dissapear, is necesary reboot by pressing menu and the central key.
Comment by Turke (obzen) - Sunday, 08 November 2009, 22:55 GMT
Try this. Download the latest build. Install it. Then go the the system settings in rockbox and turn "USB HID" option off. Then try to connect.
Comment by javier amor (chonps) - Monday, 09 November 2009, 11:42 GMT
OK, tried and it works very well. Thank you very much.
Comment by Orbidia (orbidia) - Thursday, 12 November 2009, 14:19 GMT
I'm still having this exact problem. I'm using the latest build r23617-091111 and trying to mount in XP.
The drive becomes empty after 10-15 seconds.
I've tried enabling and disabling USB HID and the same thing happens either way.

It works okay if I go from disk mode or from the boot into the apple firmware and then connect.
I just can't transfer or see any files when I connect using Rockbox.
Comment by Michael Sparmann (TheSeven) - Thursday, 28 January 2010, 01:19 GMT
The FTL parts of this problem have probably been fixed by now. The USB issues possibly not.
Please reply if you are still experiencing issues. Frank Gevaerts is currently looking into the USB HID and Mass Storage drivers.