FS#11444 - Sansa Fuze V2 USB connection kills the player

Attached to Project: Rockbox
Opened by Koczka Balint (balintx) - Monday, 28 June 2010, 20:50 GMT
Last edited by MichaelGiacomelli (saratoga) - Friday, 03 June 2011, 20:53 GMT
Task Type Bugs
Category Battery/Charging
Status Closed
Assigned To No-one
Operating System Another
Severity Low
Priority Normal
Reported Version Rbutil SVN
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I used Rockbox on a Sansa Fuze (V2) player.
The website said the usb won't work, and thee bootloader will boot up the OF if is neccessary because of USB cable plug in.

I plugged in the USB cable, while Rockbox was running.
The player's screen went black, and Windows XP Professional SP3 didn't recognized a new USB device.

I tried various methods to switch the player on. Nothing worked.
I tried to restart by holding the power button up for 10, 15, 30, 150, 263 seconds. Nothing worked.

I found this thread for this.
It says (and on IRC the users said) that I have to wait for the battery's discharge, which can take up to 6 days, because it was full of charge.

Please, fix this extremely bad bug, or warn users for this on the site, at least.
Now, because it I have to wait a week or so to use my Fuze... help.. it makes me (and lot of people who already played this) very confused.
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Friday, 03 June 2011, 20:53 GMT
Reason for closing:  Out of Date
Additional comments about closing:  We disabled a rebooting into the OF on USB insert a while ago.
Comment by MichaelGiacomelli (saratoga) - Tuesday, 29 June 2010, 05:14 GMT
Since rebooting for USB seems to occasionally cause problems, we should probably just disable it. We'll hopefully have our own USB mode soon enough.
Comment by Rafaël Carré (funman) - Tuesday, 29 June 2010, 17:09 GMT
Does the problem happen with rebooting though?

My first guess was plug detection (but i have nothing to back this off)