FS#11494 - IAudio X5: Apple Generated .aif tracks will not play in Rockbox Daily Build (r27530-100723)

Attached to Project: Rockbox
Opened by Declan Moriarty (dmoriarty) - Friday, 23 July 2010, 13:39 GMT
Last edited by Rafaël Carré (funman) - Monday, 26 July 2010, 08:59 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iAudio X5
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Playing an AIFF track recorded using Garage Band on an iMac using Snow Leapoard 10.6.4 in Rockbox Daily Build 23-Jul-2010 r27530-100723) fails.

I have a new iMac computer. I recorded a short tape using the Line In on the Mac. This was recorded using Garage Band and output to an AIFF File with bit-rate of 1411kbps and 16-bit Stereo Sample rate 44,100kHz. These numbers are identical to WAV files I have recorded on Windows XP before. iTunes reports the bit rate as 1411kbps and finder "Get Info" reports it as : 1,411,200. That last figure is is bits. I was able to write this track to CD successfully using Garage Band. This file that I tried to play on Rockbox was the direct recording from Garage Band. I also downloaded Audacity to try that. The WAV test track from Audacity played.

I tried this on Rockbox 3.6. I have now downloaded todays latest build 23-Jul-2010 (r27530-100723) and it still isn't playing.

In the following forum post Saratoga suggested I provide a test recording using Flyspray since the forums won't allow you to send large files.

Here is a test recording that won't play in the current build of Rockbox (23-Jul-2010).
This task depends upon

Closed by  Rafaël Carré (funman)
Monday, 26 July 2010, 08:59 GMT
Reason for closing:  Fixed
Additional comments about closing:  r27570