FS#11536 - m4a files won't play

Attached to Project: Rockbox
Opened by Harry Hirsch (capreolus) - Friday, 13 August 2010, 21:46 GMT
Last edited by MichaelGiacomelli (saratoga) - Saturday, 14 August 2010, 01:10 GMT
Task Type Bugs
Category Codecs
Status Closed
Assigned To No-one
Operating System Another
Severity Low
Priority Normal
Reported Version Release 3.6
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


m4a files show up in files list, but they don't start to play. example file attached. Sansa Clip+; r27796-100812
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Saturday, 14 August 2010, 01:10 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed it in r27805.
Comment by MichaelGiacomelli (saratoga) - Saturday, 14 August 2010, 01:10 GMT
File fails because it expect an MP4 header with type "M4A" but the file actually contains "m4a". Changing it with a hex editor fixes it.

Technically Apple says its supposed to be lower case, but other software I've tried doesn't seem to care, so I fixed it in r27805.

Edit: Flipped the cases around in the SVN commit message. Uppercase is correct, lower is less so.