FS#11655 - Data abort In sansa Fuze v2 when I insert 2 albums to the playlist

Attached to Project: Rockbox
Opened by Haim (haim) - Tuesday, 05 October 2010, 09:29 GMT
Task Type Bugs
Category Database
Status Unconfirmed
Assigned To No-one
Operating System Another
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


In my sansa Fuze v2 build 28208 when I insert some album to the playlist and after that I insert another album to the playlist I got this error massege:

Data abort
at 3001AE90
FSR 0x8
(domain 0, fault 8)
address 0xB0166244

This task depends upon

Comment by alexbobp (alexbobp) - Thursday, 14 October 2010, 18:07 GMT
I can reproduce this issue on my fuze v2. If I am browsing the database and I try to insert an individual file into the playlist, it is fine. But if I try to insert a whole artist or album, something that's not a real file or directory, it gives the data abort screen.
Comment by Hilton Shumway (HIllshum) - Sunday, 17 October 2010, 04:18 GMT
I have a similar crash on my Clip+.

Various combinations of playlist insertions from the database cause data aborts. The error (same every time) is:

Data abort
at 3001a73c
FSR 0x8
(domain 0, fault 8)
address 0xb011f1cc

Some combinations that will cause a crash include:

The contents of what I am inserting into the playlist make a difference (an Artist listing with 3 tracks in 2 albums may not cause a crash while an Artist with 4 tracks in 2 albums might). I'm not sure where the line there is.
Comment by Ben Leggett (phanboy4) - Sunday, 21 November 2010, 21:16 GMT
Same on my Fuze v1.
Comment by Ben Leggett (phanboy4) - Sunday, 21 November 2010, 21:17 GMT
Error message:

Data abort
at 3001B338
FSR 0x8
(domain 0, fault 8)
address 0xB017042C
Comment by Ben Leggett (phanboy4) - Monday, 22 November 2010, 19:17 GMT
Guys, try the latest build. It's working for me now.
Comment by Ben Leggett (phanboy4) - Tuesday, 23 November 2010, 05:29 GMT
Scratch that, after rebooting the device once more after installing the latest daily build, the problem pops up again.

Also Rockbox is giving me errors about "Nothing to resume" and "Invalid playlist control file", like before

Done disk check several times, hasn't fixed it.
Comment by Ben Leggett (phanboy4) - Saturday, 27 November 2010, 20:26 GMT
Hrm, after some fiddling it seems to me that the problem only occurs when something is plugged into the connector, e.g. charging cable/USB.

I get the behavior only when my car charger is plugged in and I'm using the device, and sometimes right after I unplug it, but never when I don't have anything inserted.

Comment by Chris Carpenter (mordocai) - Thursday, 02 December 2010, 09:13 GMT
Well, I'm getting the same exact error on my sansa clip+(except different addresses):

Data abort
at 3001A6E0
(domain 0, fault 8)
address 0xB010AF00

It appears to happen whether a device is plugged in or not.
On mine, it -sometimes- gives the the "Nothing to Resume" or "Invalid Playlist Control File", but will also sometimes just act like nothing happened after I reboot.
Comment by Chris Carpenter (mordocai) - Thursday, 02 December 2010, 09:58 GMT
Apologies for the double post, but I forgot ot mention that that is with the latest build...
Comment by Jeremy O'Brien (neutral) - Saturday, 19 March 2011, 11:25 GMT
Just wanted to chime in and say I also get this data abort on my Clip+ when inserting albums into my playlist.
Comment by Ben Leggett (phanboy4) - Saturday, 19 March 2011, 14:08 GMT
For me this seems to be fixed on the Fuze with the latest Rockbox release.
Comment by Jeremy O'Brien (neutral) - Saturday, 19 March 2011, 15:58 GMT
I'm running the latest svn as of today, and I can still reproduce the issue.
Comment by Cliff Free (CliffJumper) - Friday, 24 June 2011, 14:44 GMT
On Fuze V1 running release 3.8.1 (latest to date), I get the crash:

Data abort
at 3001BF8
FSR 0x8
(domain 0, fault 8)
address 0xB018F380

It happens when I "insert shuffled" (haven't tested other inserts yet), but not 100% of the time. The values above are always the same.
Comment by sideral (sideral) - Tuesday, 28 June 2011, 12:27 GMT
There's some chance that r30047 fixes this problem. Could someone able to reproduce this problem please test the fix?

This change is not part of the 3.9 release. To test it, either try a current SVN build (but beware, it could be somewhat unstable in other areas) or apply the attached backported patch on top of the v3_9 branch.
Comment by Kyle Kamperschroer (Phalangees) - Thursday, 30 June 2011, 14:54 GMT
I can confirm this bug still exists in r30101 for my Clip+.
Comment by Kyle Kamperschroer (Phalangees) - Friday, 01 July 2011, 13:49 GMT
sideral: I attempted to patch 30047 as well as 30108 and I couldn't get it patched in. I'm a little new to all of this so I apologize if I'm just making a fool of myself. Any suggestions?
Comment by sideral (sideral) - Friday, 01 July 2011, 14:19 GMT

I'm not sure I understand you right – which change are you trying to patch into which other version?

The version you said you tried, r30101, already contains the patch I've included above; so if that version still has the same problem, you're done for now – no need to do any patching. (Of course, you're welcome to try any newer version and report back when the problem goes away.)

If you're interested in how to work with patches, check out this page:
This is meant only for developers or people comfortable with building their own version of Rockbox from the source code.
Comment by Kyle Kamperschroer (Phalangees) - Friday, 01 July 2011, 14:28 GMT
Ah, I see. I must have misunderstood you. But yes, this bug still exists in 30101. I've also stepped back to 3.9 and the data abort still happens every time. Please let me know if there is anything else I can do to help out.
Comment by Kyle Kamperschroer (Phalangees) - Thursday, 07 July 2011, 17:11 GMT
Running r30128 and I have no issues anymore. I have a slight feeling it was fixed with r30122, but that is just speculation.
Comment by sideral (sideral) - Wednesday, 13 July 2011, 19:53 GMT
Thanks for the update, Phalangees!

Could anyone else having this problem please check whether a recent build makes it go away? Thanks!
Comment by sideral (sideral) - Thursday, 04 August 2011, 23:32 GMT
I just committed another patch as r30255 that addresses a bug in the database that might have caused this crash. Could someone experiencing this problem please test a recent build?