Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category FM Tuner
  • Assigned To No-one
  • Operating System Archos Recorder
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Version 3.1
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Rockbox
Opened by Anonymous Submitter - 2005-09-02
Last edited by Bryan Childs - 2010-06-05

FS#2660 - No radio on FM recorder

The main menu doesn’t show the radio entry and
The “debug menu / HW info / FM Radio” page
shows “HW detected: No” on a FM recorder

JBR FM, 20GB
Version CVS-050901

ROM: 1.23
Mask 0×0304 USB positive
PR: positive
Flash: M=BF D=D6 (I didn’t flash with Rockbox OS)
ROM CRC: 0x222F V1
ATA: 0×200, master

Closed by  Bryan Childs
2010-06-05 22:34
Reason for closing:  Out of Date
Additional comments about closing:  

If this is still an issue - we'll get it re-opened.

Anonymous Submitter commented on 2005-09-02 13:34

Logged by franck_raveau@yahoo.com

Matthias Mohr (aka Massa) commented on 2006-04-27 14:23

Does this bug still exist in newer CVS versions?
If nobody’s having this bug anymore and does report it here,
I’ll close this task in about a week from now on!

Dean Benz commented on 2007-07-03 19:06

Downloaded 2.2-2.4 and confirmed that the issue appeared between 2.1 and 2.2 apparently in the FM HW detection as 2.2 does not show the FM as detected in it’s separate menu. 2.1 does not appear to have a way to display the HW detect info, but FM works.

Dean Benz commented on 2008-03-13 18:46

Any update on this? I know it isn’t high priority, but was hoping it was just a HW detection/ID that fell out from 2.1 to 2.2 when that code changed.
Also just letting you know somebody is still out there hoping this gets fixed. :)

Steve commented on 2008-04-26 05:42

I recently had the FM radio disappear from my Sansa c250. Debug reported no hardware found. Eventually I thought to boot into the OF and the radio function worked fine there. When I booted back into RB the radio was detected and life is good again. Could this be the work in progress RB native USB connection is getting some radio bit twiddled?

John T. commented on 2009-05-29 17:10

I have a Sansa e260 that definitely still has this bug. Every version of RB I have tried on it does the same thing; “Debug > FM Radio > HW Detected: No”… Right after it was hooked to the USB cable, “FM Radio” will usually (not always) show up on the menu - but after a reboot or power cycle, it goes away for good. Radio works fine in the OF, although booting back into RB afterward does not restore the FM Radio menu option. Just updated it to v3.2, but there’s no change in the radio. It always works in the OF, so the radio is fully functional; RB simply can’t seem to find it. But this bug is definitely still present.

Marc Guay commented on 2009-05-29 17:24

Sansa users may be looking for this bug: FS#7515

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing