Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Patches
  • Category Games
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Rockbox
Opened by theli - 2006-05-03
Last edited by kugel. - 2011-06-05

FS#5282 - Rockboy for grayscale iPods

was tested on sims
(though not on 3g as it is still not working) (due to this i’m not sure about rockboy for 3g)
and on real iPod 4g and iPod mini 2g

Closed by  kugel.
2011-06-05 11:44
Reason for closing:  Out of Date
Additional comments about closing:  

There doesn't seem to be interest in this anymore. Open a new task if this is wrong.

theli commented on 2006-05-03 11:20

previous patch broke archos targets since they don’t export LCD_PIXELFORMAT at all ... ( i thought it was VERTICAL_PACKING)

now this is fixed

theli commented on 2006-05-03 13:29

oops... this is version finally fixes iPod minis

Hmm... I tried your patch with today’s CVS on my grayscale 4g. I tried opening Megaman for the original Gameboy, and I get a screen saying “Init exports / Loading default ocnfig / Init video / Init sound / Loading rom”. Then there’s a box in the middle of the screen that says “MEGAMAN”. But then nothing else happens. Any clue as to what might be wrong?

theli commented on 2006-05-05 06:38

just tried with 4g sim - works fine
you try another
can you contact me on irc (theli_ua) so we can work on
i don’t own 4g.. someone under nick zigford on irc tested this for me.

theli commented on 2006-05-05 18:48

seems as Andrés has some rockbox issues not connected to rockboy ...

theli commented on 2006-07-28 14:32

heh ... that update to rockboy with universal scaling for color lcds totally breaks this :( :(
there someone, please, who can look into?

woojj commented on 2006-08-25 16:27

i failed to compile this patch. ‘hunk failed’ message is appeared. what should i do?

theli commented on 2006-08-25 18:06

as i wrote earlier patch is out of sync and needs fixing/rework

Is this patch also intended to work with ipod mini 1g? From what I can tell it isn’t, I gotta ask though (super newbie).

theli commented on 2006-10-17 06:22

it *was* .. though now it is broken.

Ok, thanks. I figured it was now broken since I got errors with it and have used other patches successfully. Would it be worthwile to download something from around when this was made from cvs to try?

Hmmm... I downloaded the source from 2006-05-03 and tried this patch and all hunks failed. I only had 2 hunks fail trying to use this on a more current version. Did I do something wrong?

theli commented on 2006-10-18 06:13

this applied cleanly when it was
this is now obsolete and should done in other way ...

someone with more powers - close this one, please.

I would ask for this to remain open if only because an old source from around this time and this patch are right now the only way some people can get Rockboy. I appreciate and thank you for your effort and patience.

theli commented on 2006-10-19 06:43

well, i , as a developer of this patch want to say that this solution is badly designed, badly coded, and with current rockboys sources is completely obsolete.

I have now had success with this patch with the source from 2006-05-03. I didn’t realize that if I got the dying gasps message from CVS then I didn’t complete everything. Many thanks!

Anton could you update this patch for SVN please cheers

theli commented on 2007-01-29 07:00

that’s not usable with the svn code and should be closed as “deprecated” or “obsolete” and should be
that was a bad solution

Anyways, I took the old patch and adapted the code to a new version (so mostly no work done by me). The patch is synced with Build r12622. It’s working fine for me, though it sometimes crashes and then reboots...

updated for r17590m ... seems to work.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing