Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Codecs
  • Assigned To No-one
  • Operating System iAudio X5
  • Severity Medium
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Robert .S - 2006-08-10
Last edited by Dave Chapman - 2007-07-10

FS#5787 - FLAC playback buffer

Flac files only playback about 4 to 6 min of song before going to next track (sometimes 30sec). I used all versons of flac. looks like codec buffer resets its self after 2nd refill at about 10000K. sometimes playback has brokin sound. I tried reseting config settings but it does not help. everything was fine about 3 months ago. i dont know what build could of done it. Please help fix the codec buffer problem.

Closed by  Dave Chapman
2007-07-10 19:47
Reason for closing:  Out of Date
Additional comments about closing:  

User reports that bug no longer exists, or that it the problem was always due to errors in the files.

Brandon Low commented on 2006-10-29 03:16

Does this still happen with the latest code?

Michael Helmling commented on 2007-01-09 20:21

Same here, iPod nano, latest code (daily build, 9.1.2007).

Admin
Linus Nielsen Feltzing commented on 2007-05-20 06:44

Reopened again after Michael Helming reported that the issue still exists. Michael, can you tell me more about the bug? Does it always happen, or only on some files?

Michael Helmling commented on 2007-05-20 09:24

The problem occurs on my girlfriend’s ipod, with all “long” flac files (there are a few that have >10mins length). The problem didn’t go away after updating to the daily build of Jan 9,2007, as metioned before (the version that was on the iPod before might have been about half an year older).

The same files play fine on my iAudio X5 with rockbox, as well as on my computer (using amarok/xine).

Admin
Linus Nielsen Feltzing commented on 2007-05-22 07:33

Seriously, you really need to test a more recent version of Rockbox than January 9…

Michael Helmling commented on 2007-06-06 17:52

I installed a new version. Additionally, I diffed the FLACs to the ones on my computer and it turned out that there must have been some transmission errors: some of the files were different. After retransmission onto the device they now play flawless. Either that or the new rockbox version seems to have resolved the issue, so I think this can be closed.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing