Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Steve Bavin - 2007-03-06
Last edited by Steve Bavin - 2007-08-12

FS#6743 - Play button in playlist viewer should go to WPS

The PLAY button does nothing in the playlist viewer. It would be better if it went to WPS.

Closed by  Steve Bavin
2007-08-12 16:02
Reason for closing:  Out of Date
Shachar commented on 2007-04-14 21:48

Peter… You’ve made it go into the last playlist menu, not the wps.

Peter D'Hoye commented on 2007-05-01 21:26

bah… closing a task doesn’t add you to notificationslist when it gets re-opened :(

will have a look what you mean…

Peter D'Hoye commented on 2007-05-01 21:29

err… it _does_ switch back to WPS on my H380,
on what target do you see it fail?

Shachar commented on 2007-05-11 10:07

on the 11.5.07, it takes you back from the playlist viewer screen to the playlist menu. imho just like in most menus, the play button should go directly to the WPS. you already have the back and left buttons to go back one level.
btw, if you go ‘manage settings’ → ‘browse .cfg files’ then you get the same behavior: first Play (on) click takes you back to ‘manage settings’ menu, then the next click takes you to the wps screen.

Peter D'Hoye commented on 2007-05-11 12:27

Well, as I stated in my comment right above yours: on my h380, pressing PLAY in the playlist viewer *does* take me to the WPS, not the previous menu.
Same for manage settings: pressing play also brings up the WPS.

What player do you see this behaviour on? It works perfectly OK on mine….

Shachar commented on 2007-05-12 22:29

h340,
Sorry for not taking a plunge into the code, I’m rather busy for a long while :)

Steve Bavin commented on 2007-05-16 11:12

Might this be related to  FS#7176  in some way? PLAY from the playlist viewer is working for me btw, but it seems something odd is going on..

Peter D'Hoye commented on 2007-05-27 18:14

well I still stand by the ‘works for me’ closing of this task. I also have an h340 btw…

Lamed, please reset your settings and let me know if this still isn working for you, because I about to close this one again.

Shachar commented on 2007-05-29 01:12

Still, When I view the playlist it firstly goes from the playlist viewer to the playlist menu, and then if I click the play (on) button again - then it goes to the WPS. 05.28. build, reset settings.

By a _very_ quick look, I think playlist_viewer.c:622 shows that the playlist viewr screen just takes you back to the last screen like pressing ‘cancel’. I might be wrong, but I’ll have time working on this on this week.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing