Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Bootloader
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Rockbox
Opened by Alex - 2007-04-06
Last edited by Barry Wardell - 2007-11-30

FS#6984 - Sansapatcher cannot detect Sansa with FAT partition

Sansapatcher is set to detect partition in FAT32 so if the player is formatted in FAT then it will not be detected. The Sansa is by default in FAT, not FAT32 and Windows set FAT as default when formatting the Sansa as well (I think it only applies to e250 because FAT does not support anything beyond 2GB, I believe). Maybe someone can slightly change the code to detect FAT partition as well or maybe change the manual to tell people to format their players in MSC mode with FAT32.

Closed by  Barry Wardell
2007-11-30 00:19
Reason for closing:  Fixed
MichaelGiacomelli commented on 2007-04-10 03:45

This is a known issue. As I recall, FAT support broke at some point a while back and no one was very interested in fixing it. You should use FAT32.

Dave Chapman commented on 2007-04-10 08:29

sansapatcher doesn’t look inside the FAT/FAT32 partition to see how it’s formatted, it checks the partition type code in the partition table. Currently it only checks for type “0xb” which is “W95 FAT32”.

It would be straightforward to check for other valid partition type codes - assuming they are valid. i.e. if the original Sansa firmware can boot and use such a partition, then sansapatcher should support it as well.

If someone can check what partition type a non-recognised (by sansapatcher) e200 has, I’ll modify sansapatcher.

Charles Philip Chan commented on 2007-07-14 21:41
If someone can check what partition type a non-recognised (by sansapatcher) e200 has, I’ll modify sansapatcher.

This patch should do it.

Charles Philip Chan commented on 2007-07-14 21:43

Oops, I forgot to mention the partition type is FAT16.

Marc Guay commented on 2007-11-02 20:17

So has this been solved?

Barry Wardell commented on 2007-11-12 09:28

FAT16 partition type detection was added to sansapatcher quite a while ago. I think this is solved. Can someone who was having problems please report back if it works for them now?

Jan commented on 2007-11-29 21:52

I can confirm: this one is solved.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing