Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Themes
  • Assigned To No-one
  • Operating System iPod 4G Grayscale
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Shiloh Hawley - 2007-05-12
Last edited by Nicolas Pennequin - 2007-05-21

FS#7155 - Wrong day of the week displayed in WPS (%ca)

I am running firmware from May 10th on my Ipod 4g Grayscale. My WPS displays the wrong day of the week (although the date and time are correct). I am using %ca to display the day of the week. When I go to the settings to the menu that changes the date and time, the correct day of the week is displayed there.

Closed by  Nicolas Pennequin
2007-05-21 12:03
Reason for closing:  Works For Me
Additional comments about closing:  

Issue has disappeared for the reporter and can't be reproduced. Please request reopening if the problem reappears.

Jonathan Gordon commented on 2007-05-12 13:59

works here…

Nicolas Pennequin commented on 2007-05-15 09:37

Have you checked the new RTC tags format ?

Shiloh Hawley commented on 2007-05-15 21:14

I am using the tags from the wiki page. The line from the WPS is

%al%ca, %cb %cd %ar%cl:%cM%cp

Which shows the day of the week as Sun (today is Tuesday). I replied to someone else's post about this in the forums:

http://forums.rockbox.org/index.php?topic=9182.0

Shiloh Hawley commented on 2007-05-18 00:24

Update: Today is Thursday, my RB WPS says its Tuesday. Since the Day of the week is always 2 days behind, I thought I would set the year to 2008, making the day of the week Saturday, then if the WPS is 2 days behind, it would display Thursday, and the weekday and day of the month would both be correct.

When I made the change though, the WPS said Saturday. I then changed it back to 2007, and the WPS now says the correct day! I don't know why, but it seems to be fixed.

Nicolas Pennequin commented on 2007-05-18 12:55

So this was a bug with the RTC and not the WPS code… Maybe I could close this task ?

Shiloh Hawley commented on 2007-05-18 18:23

Well originally the date was correct when I viewed it from the 'set time/date' screen, only wrong on the WPS screen. So I don't know where the bug is. Maybe you should close it, and we'll see it if ever comes up again.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing