FS#7301 - Random tracks missing from Database after initialization

Attached to Project: Rockbox
Opened by Ben Mendis (sitwon) - Wednesday, 13 June 2007, 06:07 GMT
Last edited by Nils Wallménius (nls) - Thursday, 04 December 2008, 16:33 GMT
Task Type Bugs
Category Database
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I have a Sansa e280 running the latest available version of Rockbox (Ver. r13620-070611).

When I initialize the database, I always find that some tracks are missing. The missing tracks show up only in Database -> Tracks, but when I try to play them it plays something else. The tracks that are missing from the Database are visible and playable from the file-browser.

This is not an issue where I have mis-tagged files because:
1. There is only one untagged file in the Database.
2. All of my music files are properly tagged and I've double-checked the tags.
3. The missing tracks appear to be random, the ones that are missing change from one Initialization to the next. I've seen tracks or even albums dissappear, then reappear, then disappear again just from successively initializing the database. No changes to the files were made, I didn't even connect to a computer.

This is not a corrupt filesystem because:
1. I connected it to a laptop running Windows XP and ran Diskeeper and Scandisk and chkdsk on the Sansa and the problem didn't go away.

The Files are not corrupt because:
1. The files which are missing change from one initialization to the next even when the files don't change at all.
2. I can still find them in the file browser and they play fine and load all the appropriate tags.

My music folder contains 1846 files and 212 sub-folders. My music is encoded to both mp3 and ogg vorbis. The missing-tracks issue affects both mp3s and oggs.
This task depends upon

Closed by  Nils Wallménius (nls)
Thursday, 04 December 2008, 16:33 GMT
Reason for closing:  Fixed
Additional comments about closing:  Reportedly fixed, if this is still a problem request a reopen.
Comment by Ben Mendis (sitwon) - Wednesday, 13 June 2007, 06:10 GMT
I don't know if it's related, but "System -> Debug -> View database info" reports 2565 entries but I have only 1846 songs.
Comment by Michael Hahn (disorganizer) - Wednesday, 13 June 2007, 20:49 GMT
same problem here.
sometimes the db gets corrupted and even reinitializing doesnt help.
trange thing is:
if i select "artist" "xyz" "all tracks" all the tracks are shown, but as soon as i select one only a few of them are in the list.

nevertheless, after trying to reinitialize the db several times i ended up with a uninitialized db. and i was not able to initialize it (it only found some untagged voice recordings).

then doing a hard reset (15 sec on/off button) enabled me to initialize the db, and voila it worked.
i could not reproduce the problem no matter what i tried.

i have "autoupdate" activated. maybe this somehow corrupted the db or something, so i turned it off now and do a manual update when i add songs.
Comment by Sul Ayir (scdlsam) - Tuesday, 03 July 2007, 00:50 GMT
I have the same problem on my sansa e270 --

Whenever I initialize my database, a bunch of tracks from specific albums will be missing.
ALL of my files are tagged correctly, since I use TAG & Rename to name my files.

Last time I initialized it, 7 tracks from Within Temptation were missing (they seem to be random).
Sometimes whole albums will be missing.

You can fix the problem sometimes by deleting all of /.rockbox/database_ files and then initializing your database...
Comment by Marc Guay (Marc_Guay) - Saturday, 05 April 2008, 17:50 GMT
Can anyone confirm that this is still happening, and if so, find a way to reproduce it?
Comment by Ben Mendis (sitwon) - Sunday, 06 April 2008, 00:11 GMT
I haven't noticed it recently, but I have also switched to using the file-browser instead of the database whenever possible (I already have my music organized in a sensible directory structure). Over-all the database seems too buggy. It sometimes works, it sometimes doesn't, it has a tendency to break when I need it the most.
Comment by Sul Ayir (scdlsam) - Monday, 02 June 2008, 03:35 GMT
I'm pretty sure this particular bug is not happening anymore...

I'm getting a different kind of database error, but I'll test it a lot more before I open a task.
Comment by Sul Ayir (scdlsam) - Saturday, 08 November 2008, 22:14 GMT
You can close this. It's been fixed for a long time now.