Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Applications
  • Assigned To No-one
  • Operating System iriver H10
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Ben Tobin - 2007-08-22
Last edited by Nils Wallménius - 2007-10-20

FS#7642 - H10 20GB doesn't make it past the initial RockBox screen

I installed today’s build (r14428) on my H10 20GB, and it just hangs at the RockBox booting-up screen. No errors are displayed or anything. I tried resetting it several times, and I got the same behavior each time. I reverted back to my previous version (r14102) and everything was fine again.

Closed by  Nils Wallménius
2007-10-20 08:09
Reason for closing:  Fixed
Nils Wallménius commented on 2007-08-22 15:58

Could you try some daily builds to narrow down when the problem was introduced?

Ben Tobin commented on 2007-08-22 16:01

I did some experimenting, and the last version to work for me is 14288 (8/12). The problem seems to have been introduced in version 14307 (8/13).

In case it’s helpful: Overwriting the .rockbox files was insufficient when downgrading from a non-working version to r14288. It would still hang at startup. I had to delete the .rockbox directory and restore a backup of a working version, then upgrade it to 14288.

Also, whenever I upgraded to a non-working version, I would get a “scanning” message on the screen briefly before it would hang. Subsequent boots would not display this message before hanging.

Nils Wallménius commented on 2007-08-22 16:13

have you tried the hanging build with an entirely clean .rockbox dir?

Ben Tobin commented on 2007-08-22 16:28

I have now. And it does indeed work if I start clean.

Nils Wallménius commented on 2007-08-22 16:40

please report back if you find out what caused the problem, a combination of settings, corrupted database/playlist_control/nvram/config files, or whatever it might be.

Ben Tobin commented on 2007-08-22 17:52

It seems to be related to this setting: “start in screen: previous”

The previous screen in question was the playing screen. However, even setting it to “start in screen: wps” works fine. It just says “Nothing to resume”. It also needs me to initialize the database, so maybe that’s involved somehow.

I performed the following steps:
* deleted .rockbox/
* restored .rockbox/ from old working backup. (r14102)
* unzipped latest build over .rockbox/
* edited config.cfg to change “start in screen:” from “previous” to “wps” * started the player. Boots successfully. Says “Nothing to resume”.
* turned player off
* edited config.cfg and set “start in screen:” back to “previous” * started the player. Boots successfully.

Everything seems to work fine from this point on. Maybe the method of storing the “previous” state changed?

Ben Tobin commented on 2007-08-22 17:54

Oops. Between the 3rd and 4th steps, insert:
* Tried to start player. Froze on RockBox splash screen.

Alex Vanderpol commented on 2007-10-20 01:20

I think this task can be closed, this problem has been fixed a while ago, the builds had been a little “flaky” a while back (some worked but many would spontaneously crash or fail to boot), but recent builds work fine.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing