Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System Iriver H100 series
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Firestorm ZERO - 2007-11-20
Last edited by Nicolas Pennequin - 2008-07-18

FS#8194 - Scrambled playback with repeating tracking

When replaying the current track by pressing the Prev Track around a few seconds before the track ends (~15 sec or so), will play the song but after around 30 seconds in the playback will have scrambled sound (the first 30 seconds plays fine).

Problem didn’t occur maybe around 2 months ago (I don’t remember the build # of my prev) but occurs in the latest build. I can easily reproduce it.

Notes
- Playing only one track (didn’t use a playlist)
- Having Repeat One and pressing prev track to immediately replay the track (around ~15 sec before it ends) still occurs
- I mainly have FLAC files but I believe it occurs with MP3s as well (will test it soon)
- I only have a iRiver H120 to test it on

Closed by  Nicolas Pennequin
2008-07-18 23:30
Reason for closing:  Fixed
Additional comments about closing:  

This is actually the same issue as  FS#9137  . Fixed in r18090. The scrambled sound is a separate issue (see FS#9186).

Nicolas Pennequin commented on 2008-01-09 01:01

This looks very much like a manifestation of  FS#8092 . Does it still happen? My guess is that it’s fixed.

Firestorm ZERO commented on 2008-01-18 17:32

I have it rarely occur on 07-12-31 build.

I will update to the lastest and give it another try.

Firestorm ZERO commented on 2008-02-17 05:18

Had it occur on 08-01-22 build. But I can’t reproduce it as easily as first reported. It still occurred by pressing Prev Track. Will update again and see how it goes.

Steve Bavin commented on 2008-03-04 17:52

A bug was fixed that caused odd track skips when buffering recently. Is this now fixed?

Marc Guay commented on 2008-03-07 23:18

Cannot reproduce on the Sansa e200 w/ r16543.

Firestorm ZERO commented on 2008-03-17 23:24

I updated and it occurred once (very rare though). I was playing a FLAC song and close before it ended I changed the repeat to Repeat One. Half way during the song, it became scrambled. If it makes any difference I also have cross fade on.

I think maybe it was buffering the song (but it wasn’t fully buffered) and started playing it because it was the next track.

Marc Guay commented on 2008-07-13 01:28

This is very difficult to reproduce. I’ve never been able to despite trying many times in a variety of different ways and would recommend closing unless a formula can be provided.

Firestorm ZERO commented on 2008-07-13 02:04

Yeah it is very hard to reproduce. Plus I am switching to a Gigabeat F40 as my main player so I dunno if I’ll see this problem occur. Since no one else has reported anything similar, yeah I guess we should close this.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing