Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Applications
  • Assigned To No-one
  • Operating System Sansa c200
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Aaron - 2008-02-28
Last edited by Alex Parker - 2010-06-03

FS#8659 - Sansa c250 - bug in the metronome application (won't play!)

On my Sansa c250 I found a bug in the metronome application. Everything seems to be displaying correctly on the application. You can set the tempo by clicking[select] or adjusting it with the volume controls. However when it comes to actually playing the metronome by pressing the play or pause button [ > || ] nothing happens! I am a musician and this metronome application is my main reason for putting rockbox on my Sansa c250. I installed it on my brother’s iPod and I absolutely love it. Getting a good metronome is not cheap, and I hate all of the ones I’ve purchased so far… Any idea what’s going on here? Am I doing something stupid? I plan on using this to lay down some drum tracks next week if I can get it working :D
Any help would be greatly appreciated.

-Aaron

Closed by  Alex Parker
2010-06-03 17:59
Reason for closing:  Fixed
Additional comments about closing:  

Fixed with PLA rework

Larry Blowers commented on 2008-08-24 23:18

yeah it doesn’t work on a c-240 either

Maciej commented on 2008-10-01 15:06

The same problem on Sansa c250. Can someone repair it?

Johannes Linke commented on 2008-12-18 18:09

is this still valid? in the e200 its working fine…

Jonas Häggqvist commented on 2008-12-18 18:14

It’s a keymap issue, and yes, I’m pretty sure it still exists. Maybe metronome should be disabled on the c200 as long as it can’t be used?

D Richardson commented on 2008-12-20 03:37

Sansa c240 (c200 series) has not worked since the plugins inception, and never will due to a keymapping issue. I wouldn’t report this bug, as it will be overlooked, never addressed, and the developers ARE aware of the problem.

Tony Huynh commented on 2009-02-07 07:37

Turns out all that was needed to fix it was change PLA_START to PLA_UP, since the up button IS the play button on the c200; and the c200 technically has no play button iic =]

Admin
Frank Gevaerts commented on 2009-03-22 12:42

Same patch, with all unrelated changes removed

Joseph Shraibman commented on 2009-08-13 18:35

If there is a patch why hasn’t this bug been fixed?

Tony Huynh commented on 2009-08-14 10:50

I plugins are not a priority, and i guess it works fine on most other targets. Thats my guess anyways =(

Ed commented on 2009-11-19 05:39

I have an iriver h300 and the same thing happens.

for a working pitch detector to be included in the last release, it strikes me odd that nobody seems to be doing anything about the metronome? which for musical people, is just as handy if not more.

I push the buttons, I can change the tempo, but nothing happens. it jams the player and you have to swtich it off then on again.

I am running the current release as of this post (was recommended by someone as a possible fix, but no joy)

Ed commented on 2009-11-20 15:00

I thought I’d add, first off thanks for an awesome firmware,I’ve been using this firmware for some years now.

also, I thought I’d add I am using the current build as of the last post, as recommended by someone in the irc channel as a possible keymapping fix? but that didn’t fix the problem.

also, I am using the bootloader/firmware that comes with the application which automatically puts rockbox on your player. I think v5? ever since that software came out with the “stable release”.

prior to this I was patching the latest release of the iriver firmware, then extracting the current build of rockbox onto the player. I think the last two times I installed rockbox the metronome was not working. v3.3 and v3.4 I think?
I don’t know if this is useful information or not.

please can someone have a look at the metronome plugin! it’s incredibly useful for drummers, musicians, (and even djs)

I am willing to test any possible fix that won’t potentially brick my h300 (iriver h340, with 60gb drive and bigger battery, if that makes any difference)

Michael Chicoine commented on 2009-11-21 14:56

@ED-209

Which “current build” are you using. There are several current builds (sometimes many) created each day. An actual version number would help (the current version as I write this is r23679).

If you are not using release r23658 or later, the please update again. Torne corrected some issues in metronome in release r23658. This was done on 17 November which was the same day you opened  FS#10791  (http://www.rockbox.org/tracker/task/10791). That task was closed because the reported problem was fixed.

Ed commented on 2009-11-22 12:44

Yup, tried build r23679, and the metronome is working on the h300 again.
this plugin is awesome, useful for things ranging from drumming, keeping time with any instrument, to even checking your heartbeat.
many thanks!!

max bleuler commented on 2010-01-03 11:41

I made a patch for my Sansa C250 against r23658 release. I used the lines from patch in Frank Gevaerts comment . This works for me, now I just need to make the blue led blink :-) Thanks this is a great metronome!

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing