FS#9016 - AC3 Playback on iRiver H140

Attached to Project: Rockbox
Opened by David Harvey (djharvey) - Tuesday, 20 May 2008, 15:48 GMT
Last edited by Nils Wallménius (nls) - Monday, 25 October 2010, 10:18 GMT
Task Type Bugs
Category Codecs
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Whenever I try to play an AC3 file (and I've tried multiple) on my Rockboxed iRiver H140, the unit freezes. I can then only reset via the reset button on the bottom. All other files (that I know of, mostly OGG Vorbis and MP3) play just fine. It didn't do this with the build I had from a few months (?) ago. (Sorry, I know it's aggravating and terribly unhelpful; but when I upgraded, I overwrote the old build, so I'm not certain what build the old one was or even when I got it.)

Build is current (r17585-080518).
This task depends upon

Closed by  Nils Wallménius (nls)
Monday, 25 October 2010, 10:18 GMT
Reason for closing:  Out of Date
Additional comments about closing:  No response for months
Comment by David Harvey (djharvey) - Tuesday, 20 May 2008, 15:52 GMT
Oops, I realized that this was put in the category "Applications." It should be "Codecs," I think.
Comment by Steve Bavin (pondlife) - Tuesday, 20 May 2008, 18:07 GMT
Hi David,

Does this happen with any AC3 file? My sample one seems ok here. Maybe you could pop an example file up somewhere?
Comment by David Harvey (djharvey) - Tuesday, 20 May 2008, 18:13 GMT
It does, at least with all of the ones I have currently.

I've posted a zipped file here: (roughly 3.5MB).
Comment by David Harvey (djharvey) - Tuesday, 20 May 2008, 18:14 GMT Comment by David Harvey (djharvey) - Tuesday, 20 May 2008, 18:35 GMT
Hmmmmmm, I just tried it with the simulator (which uses 17585-080520), and it seems to work fine. However, when I dropped it from the simulator's build onto my H140, instead of playing (and freezing, thankfully), it now gives me "Codec Failure."

Sooooo, my guess is that the simulator's codec files aren't an exact match for what actually goes on the player, am I right? So my test actually doesn't prove or disprove anything, lol.
Comment by Nils Wallménius (nls) - Tuesday, 20 May 2008, 18:43 GMT
The simulator is not an emulator and as you say it does differ from a real target.
Try this.
Check your h140 disk for errors (using chkdsk, fsck or whatever your OS provides).
Unzip a fresh rockbox build overwriting your current one.
(maybe check if the file plays in a player on a computer (the actual file on your h140)).
Comment by Steve Bavin (pondlife) - Wednesday, 21 May 2008, 09:43 GMT
Hi David,

Sadly, your file (in isolation) plays fine on my H300, as well as on the simulator.

Maybe it's a problem when you have different foramts (or particular files) mixed? e.g. buffering an AC3 after an OGG or something wacky?
Comment by Mdkart (Mdkart) - Monday, 30 June 2008, 18:38 GMT
Are your files split files from dvd or from a big ac3 file?
Comment by Andree Buschmann (Buschel) - Sunday, 30 May 2010, 17:15 GMT
Is this error still occuring? Otherwise I would tend to close this bug report as it is outdated by far.