Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Recording
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Tuomas Airaksinen - 2008-08-16
Last edited by Michael Sevakis - 2013-07-01

FS#9286 - Rockbox hardlocks while recording

Hi,

To reproduce: start rockbox. Press record button (on sansa) so that recording screen appears and then press record button to start recording. Somewhat randomly recording hardlocks the unit after recording for some time (sometimes in few seconds and sometimes longer, up to minute (?)).

It seems this bug appears especially if you start recording as fast
as possible, while the system is still reading flash memory. Same
behaviour can be seen with different recording settings (wav,wavpack,
mp3).

This is not duplicate to  FS#8660  as I have keyclics disabled.

Configuration attached.

Closed by  Michael Sevakis
2013-07-01 00:25
Reason for closing:  Out of Date
Additional comments about closing:  

I'm not really sure that this is relevant any longer because it's rather old (2008). I can't reproduce myself either.

Peter D'Hoye commented on 2008-08-19 19:26

I do not have a Sansa e200 and the targets I have do not experience this :/
Will have to pass this on to somebody else

Peter D'Hoye commented on 2008-08-19 20:20

Unable to reproduce (on h300), and bertrik can’t reproduce on his e200

Please test again with the latest build. Report to be closed in a week if reporter doesn’t respond.

Tuomas Airaksinen commented on 2008-08-21 13:45

I tested today with the latest build (r18327). Bug still remains. I should note that it *doesn’t* appear to happen
every time, but if you try several times (5 or more) you will get this problem for sure. A workaround is to wait
a couple of seconds after going to recording screen before starting to record, so be fast if you try to reproduce.
When I was trying to reproduce this bug, I always restarted the player between each try.

In addition, I found following bug, which is probably the same bug or connected to this, so I report it here:
if you press record button (the little button with red circle with it in my Sansa) fast repeatedly such that
recording starts over and over again in a new file, you will end up getting message “Disk full. Continue by pressing UP” (straight translation from finnish Rockbox). I also got “Data abort” when trying to go away from that screen, but on second try I didn’t get data abort, only Disk full message.
I have more than 2 gigabytes free disk space left, so it really is a bug. I tried with both MicroSD card and with internal memory as a
recording folder, so it’s not a MicroSD-related bug.

Tuomas Airaksinen commented on 2008-08-21 19:14

Yet another related Data abort bug in record screen:
Start recording and manipulate gain. Keep manipulating gain while recording
until you get Data abort (you should get it in less than 60 secs).

Tuomas Airaksinen commented on 2008-08-21 19:16

By the way, should I do separate bug reports for these 3 different bugs or is it allright this way?

Bertrik Sikken commented on 2008-08-21 20:16

Sorry I can’t reproduce this. I tried this on my e200 with version r18329, downloaded with rbutil (wiped .rockbox directory in advance), then loaded your config.
On startup I see a message that says “nothing to resume” (when I switch the language to english).
I do see a UI slowdown when pressing rec quickly and repeatedly (and I’ve also seen the disk full message doing this), but I can’t make it hang.
Also could not make it data abort by manipulating gain. I’m recording on a Kingston microSDHC card.

Tuomas Airaksinen commented on 2008-08-22 04:19

Any ideas, what’s so different between our cases? It must be a more difficult to track -bug that is not triggered in all configurations…hmm..aargh. These are very annoying bugs, anyhow…

Tuomas Airaksinen commented on 2008-08-22 04:20

maybe next step is to make a complete copy of my .rockbox dir and try to reproduce with that?

Bertrik Sikken commented on 2008-08-25 19:39

I can reproduce this now on my sansa e260, with the config provided by Tuomas. It seems easier to reproduce if the recording directory is absent (it is automatically created on record). Changing the theme, the language or the backlight timeout does not seem to make a difference.

The crashes I got were data aborts in buffering.c, functions update_data_counters and find_handle. This is a bit surprising because I would not expect this code to be active during recording (but I’m not really familiar with it yet). I noticed that the theme used by Tuomas seems to have fade-out disabled, so that’s perhaps related.

Tuomas Airaksinen commented on 2008-11-06 09:58

Why is this still unconfirmed even though Bertrik already confirmed this bug?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing