FS#9760 - Sleep timer causing premature shutdown (3.0 and 3.1), codec failure (3.1)

Attached to Project: Rockbox
Opened by Steve Bateman (geokite) - Sunday, 04 January 2009, 17:09 GMT
Last edited by Andree Buschmann (Buschel) - Monday, 02 May 2011, 19:59 GMT
Task Type Bugs
Category Settings
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Low
Priority Normal
Reported Version Version 3.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Install 3.1, reboot on command, play a track from a folder, set sleep timer to 1:20, sleep apears to be working fine. Before sleep time is up, I try to change the sleep time to something longer, navi click doesn't register when selecting that new time (doesn't take me back a level), unit turns off in about 44 seconds.

On turning it on again, it says there is nothing to resume (resume is set to on) And codec failure on playing any track (previously playable mp3 files).

Install 3.0, reboot on command, a track resumes, set sleep to 5 min, navi click doesn't register, player turns off in about 44 seconds. Upon restart, the track resumes, set sleep timer to 5 min, navi click doesn't register, player turns off in about 44 seconds. Upon turning on again, no codec failure (different from 3.1)

No difference in sleep timer function if I turn off the player myself, then turn player back on, and try the sleep timer (instead of letting the player turn itself off)

I had 3.0 installed last night when I tried the sleep timer, and it kept turning off premature. Ended up just turning the unit off. Turned it on this morning and tried the sleep timer; it appeared to be working (would play past that 44 second point, and the navi click would register the sleep time). But when I changed the time to something else, it repeated the behavior described above for 3.0.

[All this is happening on an CF modded H120 (7pre4 bootloader to RAM). 32gb A-data card. And since I first wrote this, the 3.0 problem happens on an un-modded H120 with 3.1 installed (so no codec failure)]
This task depends upon

Closed by  Andree Buschmann (Buschel)
Monday, 02 May 2011, 19:59 GMT
Reason for closing:  Works For Me
Additional comments about closing:  No response, not reproducible.
Comment by Andree Buschmann (Buschel) - Friday, 11 February 2011, 16:48 GMT
Is this still valid? If not, I would like to close this bug report.