Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Patches
  • Category LCD
  • Assigned To No-one
  • Operating System Another
  • Severity Low
  • Priority Very Low
  • Reported Version Version 3.1
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Michael Chicoine - 2009-03-22
Last edited by MichaelGiacomelli - 2009-04-10

FS#10043 - lcd_e200v2 updates

This patch for the e200v2 cleans up unused GPIOs and implements LCD flipping and invert.

Closed by  MichaelGiacomelli
2009-04-10 01:44
Reason for closing:  Accepted
Thomas Martitz commented on 2009-03-23 18:05

I’ll look if it works on the fuze too!

Please do not use fixed numbers like 0xaf or 0xdb, but LCD_WIDTH/_HEIGHT (-1) instead.

Michael Chicoine commented on 2009-03-24 00:00

Here is a new version with LCD_WIDTH-1 and LCD_HEIGHT-1 instead of fixed numbers.

Michael Chicoine commented on 2009-03-27 00:51

Version 3 adds code to put lcd in standby to reduce power consumption.

Maurus Cuelenaere commented on 2009-03-27 09:50

You can remove the ‘(void)yesno;’ line (this is just to fix warnings when the parameter doesn’t get used).

Michael Chicoine commented on 2009-03-27 11:39

Additional cleanup - removed ‘(void)yesno;’ and unused function flip_lcd()

Andreas Langmann commented on 2009-03-31 12:00

works fine on e280

MichaelGiacomelli commented on 2009-04-07 16:29

Is this ready to commit?

Michael Chicoine commented on 2009-04-07 17:24

I believe so. I have not seen any problems caused by this patch.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing