Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Plugins
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by rasferret - 2009-03-24
Last edited by fg - 2009-12-17

FS#10050 - crashing pictureflow with certain podcasts on Sansa E280v1

until the r20510 there is a bug in pictureflow with certain podcasts. Take any podcast from:
http://chaosradio.ccc.de/chaosradio_express-latest.rss http://www.bitsundso.de/feed/ http://www.gamesundso.de/feed/ and rebuild database and pictureflow cache, then select one of the podcast covers. Sometimes theres a data abort, sometimes the player crashes, sometimes there are weird characters on the screen sometimes only the fonts are disappearing.
I think these files were produced with software on Mac OS X. I think they include some itunes specific tags with a lot of data, e.g. comments with many urls and such things.
I’m using a E280v1.

Closed by  fg
2009-12-17 22:36
Reason for closing:  Fixed
Additional comments about closing:  

Fixed according to the original reporter

I’ve managed to make a mp3 file that reproduces these symptoms with version r20858.
The file is located in the following path:

\MUSIC\Podcasts\Chaos Computer Club\Chaosradio Express

I’ve used a fresh version of rockbox with only database enabled. Perhaps its caused by the lyrics-tag…

with build r20941 the problem seems to be fixed…

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing