Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Plugins
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by rasferret - 2009-03-31
Last edited by teru - 2010-10-02

FS#10078 - crash in text editor

in r20588 open the attached file while playing a mp3 file. open context menu by pressing the down button. when pressing the power off button the player crashes. if there is no playback when pressing the power off button nothing happens.

Closed by  teru
2010-10-02 04:40
Reason for closing:  Fixed
Additional comments about closing:  

fixed in r28189.

you have to open the file with the text editor of course.

Can you test some archives build (and/or 3.2)? I think this bug wasn't there a few revisions ago.

I'll give it a try tonight…

I think I've tracked down the cause of the crash.
It seems to be the setting bookmark on stop. With a clean install of rockbox 3.2
and

show files: all
autocreate bookmarks: on

in config.cfg the player crashes as described before (show files: all doesn't matter but
is needed for me to start playing a file using the file browser)
With 3.1 and before the player ignores pressing the power button, so there is no crasch.
With 3.2 the player stops playback and when it tries to create the bookmark it crashes.

I hope this information is enough for tracking down the bug.

The text editor uses standard button contexts, which includes stopping playback with power. Virtually no other plugin does this.

Trying to create a bookmark when in a plugin in a backdoor'ish way can be problematic, I imagine.

teru commented on 2010-10-01 14:55

Wolfgang, could you test if the bug still happens with the latest build (r28189 at this time)?

I think the crash is gone. The text editor just ignores pressing the power button when displaying the text. When you change into the context menu the power button stops the playback and a bookmark is created.
good job :-)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing