Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Playlists
  • Assigned To No-one
  • Operating System Archos Recorder
  • Severity Low
  • Priority Very Low
  • Reported Version Version 3.2
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by tspoon - 2009-04-02
Last edited by dreamlayers - 2009-04-06

FS#10090 - Archos Recorder Shuffle Problem still not fixed (see FS#9531)

http://www.rockbox.org/tracker/task/9531

I don’t know how to re-open a task so I’ll make a new one. The behavior mentioned in the above bug is still present in 3.2 I have reverted to 3.0, as 3.0.1 also shows this behavior.

Closed by  dreamlayers
2009-04-06 14:53
Reason for closing:  Duplicate
Additional comments about closing:  

Duplicate of FS#9822

To clarify, the behavior also shows itself with a 'stop' and subsequent 'resume'. The mode is 'shuffle', but playback is sequential.

I have reverted to 3.0, as 3.0.1 also shows this behavior.

That sounds rather unlikely, since 3.0.1 contained only changes related to running Rockbox from ROM compared to 3.0.

sorry, thats true, actually the problem comes if I install 3.1 or 3.2

The playlist control file isn't being flushed. This means other changes to the playlist (eg. deleting or adding tracks) also won't be remembered. This happens because playlist_flush_callback is located and registered within an "#ifdef HAVE_DIRCACHE" block. The bug would occur on all targets with less than 8 megs of RAM.

While looking at playlist.c I noticed a related problem which I can reproduce on my 5G 30GB iPod with r20607: If the disk doesn't spin down, the playlist control file isn't flushed. This is easiest to reproduce if you set a long disk spindown time, though continuous user activity can also keep the disk spinning. Perform the following actions without spinning down the disk: start playback, modify the playlist (eg. delete a track), stop playback and resume playback.

zipr commented on 2009-04-06 13:05

This is the same bug I entered here, I believe..
http://www.rockbox.org/tracker/task/9822

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing