Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category LCD
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by DarkSpectrum - 2009-04-06
Last edited by fg - 2009-12-17

FS#10103 - Backlight on Hold

The Option “backlight on hold: normal” in the display settings does not work correctly. When this setting is selected and the units hold switch is turned on the backlight will stay on it’s defined time and turn off but any button press afterword will not turn the backlight back on. When this setting is selected the unit should wake the backlight back up when the units hold switch is on and a button is pressed.

“backlight on hold: off” & “backlight on hold: on” do work correctly.

Tested on both Sansa C200 & E200

Closed by  fg
2009-12-17 22:43
Reason for closing:  Not a Bug
Additional comments about closing:  

Hold means that buttons do not work.

Not a bug IMO.

If this is the intended behaviour (which I doubt) then perhaps we should only offer “On” and “Off” options for “Backlight on hold”.

This is intended, AFAIK. And it ever worked like that.

I’m inclined to close. It really should be intended behavior.

hold button is handled in each target’s button driver, blocking button reads while the hold switch is on. Hence, there’s no way to to turn the backlight on during hold without rewriting every single button driver.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing