Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Patches
  • Category Drivers
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version Version 3.2
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Dustin Skoracki - 2009-04-19
Last edited by Thomas Martitz - 2009-04-29

FS#10151 - e200v2: scrollwheel acceleration

This patch by kugel and me enables scrollwheel acceleration for the e200v2: fast wheel turning will cause lists to jump over items for fast scrolling.

Closed by  Thomas Martitz
2009-04-29 20:50
Reason for closing:  Accepted
Additional comments about closing:  

Committed in r20822. Good work!

Dustin Skoracki commented on 2009-04-21 19:08

Here is a new patch, it's compiling again (old patch didn't work since r20757), has a little faster acceleration and is more simple.

Dustin Skoracki commented on 2009-04-23 14:35

New one: a little more time between to wheelclicks to be recognized as repeat and a little comment change to make it more clear.

Michael Chicoine commented on 2009-04-23 21:22

Seems to work well on my e260v2

Thomas Martitz commented on 2009-04-26 11:09

During a missed read, you're not executing scrollwheel(), is that intended? I'd think you get more smooth acceleration if you executed it anyway (it'll give the same button, but increase repeat).

Dustin Skoracki commented on 2009-04-26 12:46

Yes, at the last try it was intended, but it worked not as good as the first try, so, here is a new patch which executes scrollwheel during a missed read (very similar to first patch).

Dustin Skoracki commented on 2009-04-26 18:14

This is basically the same patch than the one before, but with imo better acceleration behavior.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing