Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Version 3.2
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Jaykay - 2009-04-23
Last edited by Buschel - 2011-02-03

FS#10163 - wierd behaviour when changing folder name while plaing music in it

second category: playlists. sorry for the long text.

well, it’s quite easy to reproduce: play some music in a folder. i guess the music should not fit into the buffer. then change the folder name of a parent directory.

music continues as normal. but if you skip a few times to the next track (i think other actions are also possible, and sometimes skipping doesn’t work….) the music stops.

from now on it’s not possible to skip or play music. ff/rw is possible, but the music doesn’t play afterwards. selecting other music doesn’t work, right now rockbox apparently freezes at the “loading…“-splash. only a hard reset helps.
the cpu-frequency is at the max, boost is 100%.
and shutting down needs ~10s, maybe due to the high cpu-load.

if you create a playlist with some songs from one folder in it, change the name of the folder, start the playlist, and quickly press PLAY, you will see the information of a song of the playlist. i think its the song which is currently loaded, if you press PLAY immediately after selecting the playlist, it will be son no. 10 or such. if you wait, it will be a song which is more at the end of the playlist. if you wait longer (i guess when the playlist is completely loaded) it will be track one. in any case, the time of the song is 0:00 and doesn’t increase; rockbox doesn’t play music. after a while it shows shortly (root) (root), and then goes to the main menu.

i think there are some more interesting things to discover :) if nobody knows the cause for this at once, i’ll do some further “tests”.

Closed by  Buschel
2011-02-03 20:36
Reason for closing:  Duplicate
Additional comments about closing:  

Renaming the folder is logically the same as deleting the file. A bug report which describes file deletion during playback is FS#10874. This report will be closed, further discussion should be moved to FS#10874.

this is another of those bugs which I just have to ask.. why the heck are you deleteing the file thats playing? OF COURSE its going to casue problems

where did i say that i delete anything? i ONLY change the name of folders.

this is another of those bugs which I just have to ask.. why the heck does rockbox allow deleting/changing the name of music which is currently played? OF COURSE some dumb user will post bug reports about it

sorry, please don’t be offended :)

and of course it’s a bug, especially 100% cpu load and freezing

Renaming a parent folder will appear to be a deletion (i.e. \Artist1\Album1\Track08.mp3 no longer exists).

However this should just skip the track(s), not go into any strange mode.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing