Rockbox

Tasklist

FS#10169 - Track info doesn't update on WPS following backlight fade-out

Attached to Project: Rockbox
Opened by David Thacker (epithetless) - Monday, 27 April 2009, 19:17 GMT
Last edited by Thomas Martitz (kugel.) - Monday, 27 April 2009, 20:15 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Once the backlight shuts off on my e280, the current and next track info fails to update with song changes.

To reproduce:

- Play any given song in a playlist or directory
- Allow the backlight to fade out and then let the player play into another song
- Scroll the volume wheel or press the pause button to reactivate the backlight -- Although the playlist position and track time have been updating as expected, the current track and next track information displayed will still be for the song that was playing when the backlight initially faded out. This is especially apparent if you have the "First Buttonpress Enables Backlight" option enabled, since that first button press will immediately bring you to the WPS.

WPS information will refresh and display correctly once the file browser is accessed and the WPS is returned to, or when the next track button is pressed.


I don't know how long this bug has been present, but I became aware of it with the last few builds (it is present in r20809, the latest at the time of this writing).
This task depends upon

Closed by  Thomas Martitz (kugel.)
Monday, 27 April 2009, 20:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in r20812
Comment by David Thacker (epithetless) - Monday, 27 April 2009, 19:30 GMT
Well, that was fast. The reversion made in r20812 seems to have fixed it.

Loading...