Rockbox

Tasklist

FS#10179 - Lines do not scroll in the file browser (at least in simulator)

Attached to Project: Rockbox
Opened by Alexander Levin (fml2) - Thursday, 30 April 2009, 22:24 GMT
Last edited by Alexander Levin (fml2) - Friday, 01 May 2009, 11:15 GMT
Task Type Bugs
Category LCD
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

In the e200 v1 simulator, if I position the cursor on a long name in the file browser, it does not scroll. This happens in r20829. With r20828, everything works as it should. Hence r20829 must have introduced a bug.

I have not tried whether the same happens on target.
This task depends upon

Closed by  Alexander Levin (fml2)
Friday, 01 May 2009, 11:15 GMT
Reason for closing:  Works For Me
Additional comments about closing:  The problem does not happen on the latest simulator versions
Comment by Yoshihisa Uchida (Uchida) - Friday, 01 May 2009, 06:28 GMT
I was not able to confirm this problem in the latest version (r20833).
Could you confirm operation by using the latest version?
Comment by Alexander Levin (fml2) - Friday, 01 May 2009, 09:21 GMT
Hrm... With r20834 I can't reproduce the problem too.
Comment by Yoshihisa Uchida (Uchida) - Friday, 01 May 2009, 11:04 GMT
I confirmed again. But this bug does not happen (r20384).
Operation did not change though I confirmed by both my build simulator and Rasher's build simulator (http://rasher.dk/rockbox/simulator/sansae200-sim-w32.zip).

use font: 08-Schumacher-Clean, 12-Adobe-Helvetica, 12-Nimbus, 13-Nimbus, and 16-GNU-Unifont.
check file name: very_very_long_filename_textfile.txt

Loading...