Rockbox

Tasklist

FS#10186 - Conditional display of Replay Gain tag illogical?

Attached to Project: Rockbox
Opened by Stefan Waldmann (Rockfan) - Sunday, 03 May 2009, 16:59 GMT
Last edited by Paul Louden (Llorean) - Monday, 04 May 2009, 23:24 GMT
Task Type Bugs
Category ID3 / meta data
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Daily Build r20848-090503

... from the manual
%rg

ReplayGain value in use (x.y dB). If used as a conditional, Replaygain type in use: %?rg<Off|Track|Album|TrackShuffle|AlbumShuffle|No tag>

Conditional display of Replay Gain tag.

now:
| if || Shuffle On | Shuffle Off |
-----------------------------------------------------
| Track Gain || Track | Track |
| Album Gain || Album | Album |
| TG if Shuffle || TrackShu | AlbumShu |

shouldn't that be:
| if || Shuffle On | Shuffle Off |
-----------------------------------------------------
| Track Gain || TrackShu | Track |
| Album Gain || AlbumShu | Album |
| TG if Shuffle || TrackShu | Track |

or:
| if || Shuffle On | Shuffle Off |
-----------------------------------------------------
| Track Gain || TrackShu | Track |
| Album Gain || AlbumShu | Album |
| TG if Shuffle || TrackShu | Album |

???.

But maybe I'm completely wrong ...
This task depends upon

Closed by  Paul Louden (Llorean)
Monday, 04 May 2009, 23:24 GMT
Reason for closing:  Not a Bug
Comment by Paul Louden (Llorean) - Sunday, 03 May 2009, 23:01 GMT
Could you please try to describe what you think happens with words or the syntax we use, rather than your tables? I can't tell what you mean by them at all.
Comment by Stefan Waldmann (Rockfan) - Monday, 04 May 2009, 06:51 GMT
OK, let me try to explain the tables first (... my English is not that good).

There's two things you can select in Rockbox:

1. in "Settings" - "Playback Settings" - "Shuffle": No/Yes
This is the first row of the table (to the right of "if")

2. in "Settings" - "Playback Settings" - "Replaygain" - "Replaygain Type": TrackGain/Album Gain/Track Gain if Shuffling
... the first column of the table (below the "if")


The crosspoints of row and column illustrate what is displayed from the line
%?rg<Off|Track|Album|TrackShuffle|AlbumShuffle|No tag>
if you choose a pair of settings (... tags must be present) or in detail:

First table - this is actually displayed,
second or third table - that is what i'd expect.


... thanks for answering and sorry for my bad English ...
Comment by Paul Louden (Llorean) - Monday, 04 May 2009, 06:56 GMT
Why would you expect these differences? The only time AlbumShu or TrackShu should display is if "trackgain if shuffle" is enabled, as they're the values specifically for it.

If you wish to show something if shuffle is enabled, and regular track gain is true, there are already conditionals you can combine to make this happen. The unique conditions of "trackgain if shuffle" and "shuffle yes" or "shuffle no" can't be reached by way of them because the RG tag tells the actual RG status, not the value of the setting, so you can't test for which mode it's set to, just which behaviour is happening.
Comment by Stefan Waldmann (Rockfan) - Monday, 04 May 2009, 12:11 GMT
Thanks for clearance, so this is no bug.

Loading...