Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Codecs
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Carlos Santos - 2009-05-22
Last edited by Dominik Riebeling - 2009-06-04

FS#10228 - mpeg and wma files do not play

I think it might be a codecs problem, but for some reason, I can find the wma and mpeg files (I uploaded the wma by winamp and the video by explorer), but for some reason they don’t play. Any help?

Closed by  Dominik Riebeling
2009-06-04 19:47
Reason for closing:  Not a Bug
Additional comments about closing:  

This is pretty much a support question. Use our support channels (IRC, mailing lists, forums). We do not provide any support in the tracker.

Nils Wallménius commented on 2009-05-22 09:09

Please give a little more details, _what kind_ of wma file is it and _what kind_ of mpeg file is it, there are several different types of both.
What happens when they don’t play? any error messages?

Carlos Santos commented on 2009-05-23 21:43

Well, the video is mpeg4 format, and the error is as follows:
I enter into the ‘files’ section, go to my folder titled ‘movies’, I select said file, andthe track listing says ‘TB’, then ‘c’, Artist and Album say ‘Root’, and it says the file size is 0kb.

As for the wma, it just flips through every track on that album until it hits the point where title and artist say ‘root’.

And as for the type of file it is, not sure what you mean, it is windows media audio, not sure if you want bitrate details?

Carlos Santos commented on 2009-05-24 23:17

Anyone able to help?

Magnus Holmgren commented on 2009-05-30 09:30

MPEG4 video is not supported, so it isn’t strange that those files don’t play.

As for WMA, there are several kinds of WMA. E.g., they could be DRM-protected (even if you ripped them yourself) or use the WMA Pro codec, and neither are supported by Rockbox.

Carlos Santos commented on 2009-05-31 14:45

So, what kind of MPEG files are supported?

Carlos Santos commented on 2009-05-31 21:43

So, what kind of MPEG files are supported?

Nils Wallménius commented on 2009-06-01 11:54

well regular mpeg1 audio layer 1, 2 and 3 (mp3) audio is supported as well as mpeg1 and mpeg2 video

Dominik Riebeling commented on 2009-06-02 16:49

Please don’t double post. It won’t get you a faster answer. Furthermore, please search the website yourself. For video, only MPEG1 and MPEG2 is supported (see the PluginMpegplayer wiki page or the manual). For audio nls already answered the question. As for the wma file please give more details, otherwise I’ll close this as not a bug.

Carlos Santos commented on 2009-06-03 00:58

I didn’t mean to double post, my page refreshed. Also, I converted to mpeg1, and I tried again, and got the error “Error opening file: -1” then “Plugin returned error”.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing