Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface → Themes
  • Assigned To
    jdgordon
  • Operating System Another
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by mcuelenaere - 2009-05-28
Last edited by mcuelenaere - 2009-08-01

FS#10259 - WPS bug while playing some music files as first song

I have this bug on some songs, but not on all (haven't determined what difference there is between the working & non-working).

When it gets triggered it, the variable 'value' at l.1405 (gwps-common.c) has an invalid value which triggers a memory exception at l.1411 (same file).

However when I play the same file after I played a working song (e.g. through the playlist) it doesn't get triggered…

Tested on: Onda VX747, SVN r21112'ish

(I'll look into this when I have some more spare time)

Closed by  mcuelenaere
2009-08-01 19:38
Reason for closing:  Fixed
Additional comments about closing:  

In r22104.

Today I couldn't reproduce this specific bug anymore, however I have exceptions (== data aborts on ARM) when running some MP3's, FLAC & WAV files as the *first* song.
But when I play a (working) MP3 file as first and then switch to one of these others, they work..

Will post more of this :)

SVN r21136

If I add a splashf(HZ, "before"); at l.1410 of gwps-common.c, the song starts to play but the screen show only parts of the WPS and I can't do anything anymore (even though the song plays), so I suppose this is something with the codec thread..

If I don't add a splashf(), I get an exception around there regarding an invalid value of the variable 'value' I think (this smells like data corruption.. perhaps I should look into saving more registers when switching threads ..)

Seems like %?C<|%ac%?ig<%ig|» causes a crash on my Onda VX747

edit:
confirmed

edit2:
Somehow, the genre_string item of struct id3 gets cluttered to an invalid string pointer and so crashes the device..

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing