FS#10266 - Cannot switch ipod on/off on a Bose docking station

Attached to Project: Rockbox
Opened by musiq son (musiq) - Sunday, 31 May 2009, 10:11 GMT
Last edited by Dominik Riebeling (bluebrother) - Tuesday, 02 June 2009, 16:46 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System iPod 4G Grayscale
Severity Low
Priority Normal
Reported Version Version 3.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



On a BOSE docking station, when rocknox is executed, the iPod cannot be switched off or on, neither with the wheel pad, neither with the BOSE remote. When setting it back to Apple mode it works fine.
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Tuesday, 02 June 2009, 16:46 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  This is turning into a support issue. You can set the backlight to turn off if connected to power. As been said, you can't turn of an Ipod if connected to power. For further discussion please take this to the support channels. We don't accept feature requests here.
Comment by musiq son (musiq) - Sunday, 31 May 2009, 10:16 GMT
the exact brand is : Bose® SoundDock® Digital Music System
Comment by Paul Louden (Llorean) - Sunday, 31 May 2009, 10:52 GMT
Ipods can't actually be turned off while they're charging. What you're seeing in the original firmware is simply it faking being off by going into a low power mode with the screen off.
Comment by musiq son (musiq) - Monday, 01 June 2009, 17:46 GMT
ok, then it should be possible to do the same to save power and at least because in my case the dock is in the sleeping room.
Leaving the display on is not that good to sleep :)
I also noticed that the play/pause command is damn slow at responding on the Ipod 4G, this is not the case with the regular apple firmware.

Comment by Paul Louden (Llorean) - Monday, 01 June 2009, 17:53 GMT
Please don't report other bugs as comments to this one. If you have separate problems, seek support in the forums. If you think it's a bug, post a new task.

As to the screen, are you having troubles with the backlight controls?