FS#10337 - Music only plays partially before it freezes with error, requiring hard reset

Attached to Project: Rockbox
Opened by Aleksey Borisov (k00ld00dz) - Monday, 15 June 2009, 14:55 GMT
Last edited by Steve Bavin (pondlife) - Wednesday, 17 June 2009, 13:31 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Version 3.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I am having problems playing music. I can only play it for some time before the ipod crashes on me. I have converted an mp3 file into a wav and wma file to test if the problem persists only on certain formats, and I have found that mp3 files will play for about 20 seconds before crashing, wav about 5 seconds, but wma files work just fine and play all the way through. Im thinking it must be something to do with the codecs, but I dont know.

When the Ipod crashes, I get these messages; "Undefined instruction at 03E808A4 (0)" for mp3 files, and "Data abort at 00009E7C (0)" for wav files. Then I must "Hard Reset" the Ipod in order to unfreeze it.
This task depends upon

Closed by  Steve Bavin (pondlife)
Wednesday, 17 June 2009, 13:31 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Support questions should be on the forum, mailing list or IRC.
Comment by Dominik Riebeling (bluebrother) - Monday, 15 June 2009, 17:42 GMT
What build have you installed? 5G 30GB or 5G80GB? How did you install?