Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Codecs
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Low
  • Priority Very Low
  • Reported Version Version 3.2
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by simonprosser - 2009-06-23
Last edited by stripwax - 2009-10-03

FS#10376 - Undefined instruction at 03E80478 (0) after playing an ogg file.

HW: iPod 5.5 Gen 60GB
Bootloader: ?? how can i check?
Build: 3.2-090323

Problem: Undefined instruction at 03E80478 (0) after playing an ogg file.

What I did:
1. Used iTunes to install mp3s.
2. Then I used rockbox installer.
——-I was able to play mp3s no problem.——– 3. Then I put ogg files on and tried to play (via file browser), then I got the undefined instruction.
4. After this i boot up into rockbox again and still get it for mp3s now.

Please let me know how to provide the information required to fix this bug. I can probably get my hands on a serial cable if you need me to hook it up to putty. This is 100% reproducible. Let me know how to provide the right information to fix the bug and I will. Can I get an old build from anywhere that still works?

This time I reinstalled rockbox on a player without ogg files, then I tried a few times (before putting oggs on it) and am getting Undefined instruction at:
03E80974 (0) → this happens on any file that media money converted from ogg to mp3 (160kbps vbr). (this happened twice).
03E80478 (0) → this happened with a Q5 ogg file i dragged onto the device (connected to vista with rockbox bootloader).
03E804D0 (0) → this happened with a Q5 ogg file i dragged onto the device (connected to vista with rockbox bootloader).
03E8097C (0) → not sure if this is ogg or mp3.
03E804D4 (0) → not sure if this is ogg or mp3.

This doesn’t happen on my iriver H340.

Closed by  stripwax
2009-10-03 18:02
Reason for closing:  Out of Date
Additional comments about closing:  

Most likely fixed when a recent crash fix got committed, not enough information to reproduce

Please check if installing the 5.5G 30GB build “fixes” this.

Is the bug apparent in versions prior to r20783 (which incorporated a number of libtremor changes) ?

Closing due to lack of response and recent tremor crash bugfixes that probably fixed this issue also

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing