Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface → Simulator
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by aidy - 2009-07-19
Last edited by kugel. - 2009-09-23

FS#10451 - backlight off on hold doesn't function properly

rev 21966

I don’t know if this is intended behaviour or not, but when you enable ‘backlight off on hold’ in the simulator and enable hold mode, the screen only goes black once you press a key.

Closed by  kugel.
2009-09-23 17:01
Reason for closing:  Fixed
Additional comments about closing:  

Fixed in r22799.

aidy commented on 2009-07-19 19:33

It seems that it happens on the actual targets too, once you enable hold, nothing happens and the backlight goes off after the normal time-out instead of immediately.

This was originally reported on the Cowon D2, but aidy also reported that it happens in an X5 sim build. The problem is that “Normal” and “Off” settings both appear to wait for the same length of time before the backlight goes off.

The D2 and X5 both use BACKLIGHT_FADING_SW_HW_REG, if this is a clue.

r22007 fixes the backlight-on-hold timeout issue on the D2, but does not change the behaviour of the sim.

That should fix it. It gets rid of the seperate button driver and uses what targets use also. Should’ve been done long ago :/

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing