Rockbox

Tasklist

FS#10452 - Most jpeg albumart not loading (gimp jpg)

Attached to Project: Rockbox
Opened by Paul Seropian (nospaulatu) - Monday, 20 July 2009, 04:03 GMT
Last edited by MichaelGiacomelli (saratoga) - Monday, 20 July 2009, 13:25 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Version 3.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Most jpeg/jpg albumart I put on my 60gb 5G IPod does not display. Most albumart I use has been edited with The GIMP running on Linux, though other software has no trouble reading these files.

I tested this with the current build (July 19, 2009), but this has been an ongoing problem ever since jpeg albumart support has been added. Loading these files with the jpeg viewer plugin displays an error message "unsupported -4".

I have attached a sample jpg image that does not load on rockbox.
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Monday, 20 July 2009, 13:25 GMT
Reason for closing:  Not a Bug
Comment by Paul Louden (Llorean) - Monday, 20 July 2009, 05:03 GMT
Progressive jpeg isn't supported. This is documented in the manual

Loading...