• Status Unconfirmed
  • Percent Complete
  • Task Type Bugs
  • Category Games
  • Assigned To No-one
  • Operating System Another
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by yelped - 2009-07-31

FS#10481 - Doom Gets a Data Abort Error

On the Official Test Build for the Sansa Fuze, when playing Doom, in middle of playing, Rockbox gives a Data Abort Error. If it doesn't happen in middle of playing, it is always reproducible by entering the second Map. The most recent error i got is "Data Abort at 307B32D4". My Version is "r21704-090707".

It happened once just browsing through the Menu, but is only reproduced every time by playing Doom, which is why I filed it under Doom.

I will try to try a later revision and see if it fixes the bug.

I tried version r22090-090730 and I get "Data abort at 307B3260", also at the same place when entering the second map in Doom. It happens other places, just here it is reproducible.

That address is doom's free() function. tried this in the sim and its used 4.5MB of RAM by the second map, which is about how much is available to doom on the Fuze. It probably runs out of memory and then crashes.

So, it's not corruption? Thanks for the info, that's what I was really worried about.

I get the same error on the iPod Video, and it's upon entering the game itself. However, the "307B32D4" is a different combination, I can't remember though.

Should doom be disabled on the fuze? It seems a bit sad actually.

i have no problems on my fuze 8GB V1 with the doom shreware

But it occurs in freedoom: solution :-)

i downloaded all version (there a new doom.wad files from times to times) and some work others not

if you disable every option sound…headsup display…stausbar always read this error should not occur

there is also a new version of freedoom ultimate with three levels you can play 2 & 3, 1 is breaking down

Still reproducible on my 2GB Version1 Fuze, r26245.

It's either a DATA ABORT (common), a freeze, or a DIVIDE BY ZERO error.


Available keyboard shortcuts


Task Details

Task Editing