Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Codecs
  • Assigned To No-one
  • Operating System iriver H10
  • Severity Low
  • Priority Very Low
  • Reported Version Version 3.3
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Sabrena - 2009-08-07
Last edited by Magnus Holmgren - 2009-09-07

FS#10492 - Data abort error

Data Abort at 01E8DD28

This error message only applies to ogg vorbis files, the player completely freezes up and I have to hit the reset button to play any of my music.

Closed by  Magnus Holmgren
2009-09-07 19:46
Reason for closing:  Fixed
Additional comments about closing:  

Fixed in r22653.

MichaelGiacomelli commented on 2009-08-07 20:19

Can you upload a file that has this behavior?

Sabrena commented on 2009-08-08 15:01

This is the main file I tested and found the problem with but I have tried other ogg vorbis files and found the same issue.

Magnus Holmgren commented on 2009-08-09 13:33

I have a file with a similar problem. In both cases, the crash is in floor1.c (in the simulator). For the above file, the crash is a segfault in render_line (though I couldn’t easily see in the debugger exactly what caused the segfault), in “my” file, it is a division by zero in render_point (due to x0 and x1 being zero). In both cases, it could be caused by incorrect creation of or reading from info→postlist…

Tremor SVN from July 2009 works fine. Reverting the changes in render_point makes no difference.

Magnus Holmgren commented on 2009-08-30 07:07

I tested again with (a custom build of) r22540 and that worked fine. Would be nice to know why it worked now though…

Dave Hooper commented on 2009-08-31 18:09

The crash (on sim at least) for that file appears to be due to accessing array out of bounds. In particular, the x and y values in render_line look totally wrong, and cause us to try and access invalid elements of the output buffer and/or the fromdB lookup. Definitely looks like a packet is mis-decoded and we try and render garbage.

Magnus Holmgren commented on 2009-09-01 18:24

Based on a message on the mailing list, I tested simulator builds of 3.2 and 3.3. 3.2 works, 3.3 fails, so that points to  FS#9882 .

(Edit) Additional note: iram_pcm_doublebuffer (in block.c) is false for the failing files.

Sei Aoyumi commented on 2009-09-03 12:25

I made the patch which revised this problem. In addition, this patch keeps the memory allocation of the (1st) PCM buffer simple form than before.

Magnus Holmgren commented on 2009-09-03 19:05

Thanks. That works for my test tracks on an e200, and the above file in the simulator.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing