Rockbox

Tasklist

FS#10533 - USB Charging mode represents player a diffent one

Attached to Project: Rockbox
Opened by Seheon Ryu (cpu98) - Sunday, 16 August 2009, 15:35 GMT
Last edited by Frank Gevaerts (fg) - Sunday, 16 August 2009, 23:32 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

UMS mode and Charging only mode has different ID
Is it a feature?
This task depends upon

Closed by  Frank Gevaerts (fg)
Sunday, 16 August 2009, 23:32 GMT
Reason for closing:  Not a Bug
Comment by Frank Gevaerts (fg) - Sunday, 16 August 2009, 23:32 GMT
The two modes have a different serial number. This is on purpose, because some host operating systems use the serial number to store information about which class drivers to load, and do not handle changing interfaces properly.

Loading...