Rockbox

Tasklist

FS#10542 - No value listed in Scroll bar position screen

Attached to Project: Rockbox
Opened by Rosso Maltese (asettico) - Tuesday, 18 August 2009, 13:46 GMT
Last edited by Maurus Cuelenaere (mcuelenaere) - Tuesday, 18 August 2009, 18:37 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

In the screen "Scroll bar position" are showed no value.
I think that the related management function has not been implemented, as the last argument in apps/settings_list.c row 611 is NULL.

Referred to r22406.
This task depends upon

Closed by  Maurus Cuelenaere (mcuelenaere)
Tuesday, 18 August 2009, 18:37 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r22410.
Comment by Maurus Cuelenaere (mcuelenaere) - Tuesday, 18 August 2009, 14:01 GMT
I don't think that's related, that argument is used as a callback when the setting gets changed (it is NULL because no callback should be used, the list code will pick this up itself when drawing).

This is probably language related though, I've seen this once too; but can't reproduce it.. (LANG_YES & LANG_NO didn't show up, perhaps this has to do with undeprecating them?)
Comment by Rosso Maltese (asettico) - Tuesday, 18 August 2009, 14:28 GMT
The strange this is that the items are not showed, but they are there!
If you scroll the selection bar as if it's visible, the setting is changed.
Comment by Rosso Maltese (asettico) - Tuesday, 18 August 2009, 14:32 GMT
About the NULL argument: I don't know the RB API, I simply compared that definition with the BOOL_SETTING item at line 576, but now I understand the difference. Sorry.

Loading...